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"Processing error occurred" when you detect status of Active Directory in Windows Server 2012 R2-based domain controller


View products that this article applies to.

Symptoms

Assume that you open Group Policy Management Console (GPMC) on a Windows Server 2012 R2-based domain controller. You click Detect Now to check the status of Active Directory and Active Directory System Volume (SYSVOL) replication for the domain. In this situation, you receive the following error message:
A Processing error occurred collecting data using this base domain controller. Please change the base domain controller and try again.

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Cause

This issue occurs because GPMC tries to retrieve the domain controller name by using both the DsGetDcName and DsGetDomainControllerInfo functions. The comparison between the two functions fails with the previously mentioned error message if DsGetDcName returns a name that contains lowercase letters.

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Resolution

To resolve this issue, install update rollup 2975719. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
2975719 August 2014 update rollup for Windows RT 8.1, Windows 8.1, and Windows Server 2012 R2

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Workaround

Important
Follow the steps in this section carefully. Serious problems might occur if you modify the registry incorrectly. Before you modify it, back up the registry for restoration in case problems occur.


The DsGetDcName function reads the name information from "HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Hostname." To work around this issue, check the Hostname registry entry of a domain controller, convert the value of the Hostname registry entry to all uppercase, and then restart the netlogon service on the domain controller.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about the DsGetDcName function, go to the following Microsoft website: For more information about the DsGetDomainControllerInfo function, go to the following Microsoft website:For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbqfe, kbfix, kbsurveynew, kbexpertiseadvanced, kb

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Article Info
Article ID : 2979923
Revision : 1
Created on : 1/7/2017
Published on : 8/12/2014
Exists online : False
Views : 353