Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Shared folder in Windows Server 2012 R2 or Windows 8.1 cannot be accessed by using SMB version 1 protocol


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You create shared folders on a computer that is running Windows Server 2012 R2, Windows 8.1, or Windows RT 8.1.
  • You enable SMB version 1 protocol on the computer.
  • You try to access the shared folders by using SMB version 1 protocol from a computer that is running Windows Server 2003 R2 or Windows XP.
In this scenario, you randomly receive the error message that resembles as follows:
"The specified network name is no longer available"

↑ Back to the top


Cause

This issue occurs because there is a race condition between SMB version 1 Service driver loading and the Server service initialization.

↑ Back to the top


Resolution

To resolve this issue, install update rollup 2975719. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
2975719 August 2014 update rollup for Windows RT 8.1, Windows 8.1, and Windows Server 2012 R2

↑ Back to the top


Workaround

Important
Follow the steps in this section carefully. Serious problems might occur if you change the registry incorrectly. Before you change it, back up the registry for restoration in case problems occur.


To work around this issue, change the following registry value on the computer on which you create a shared folder. To do this, follow these steps:
  1. As a local administrator, run Registry Editor.
  2. Explore to the HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\LanManServer.
  3. Right-click DependOnService registry entry, and then click Modify.
  4. In the Value data box, type SamSS Srv2 Srv, and then click OK.
  5. Exit Registry Editor.
  6. Restart the computer.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: kb, kbqfe, kbfix, kbsurveynew, kbexpertiseadvanced

↑ Back to the top

Article Info
Article ID : 2976994
Revision : 1
Created on : 1/7/2017
Published on : 8/12/2014
Exists online : False
Views : 268