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"The CA certificate could not be retrieved, element not found" error occurs when the CA server host name is longer than 52 characters


View products that this article applies to.

Symptoms

If the Certification Authority (CA) server host name is longer than 52 characters, you receive the following error message when you select the CA name in Online Certificate Status Protocol (OCSP) revocation configuration:

The CA certificate could not be retrieved, element not found (exception from HRESULT: 0x80070490)

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Cause

This problem occurs because OCSP searches the CA by the displayname field. In this case, the CA's displayname field is truncated if it is longer than 52 characters. This causes the CA object not to be found.

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Resolution

To resolve this issue in Windows 8.1 or Windows Server 2012 R2, install update rollup 2962409, or install the hotfix that is described in this article.

To resolve this issue in Windows 7 or Windows Server 2008 R2, install the hotfix that is described in this article.

Update information

For more information about update rollup 2962409, click the following article number to view the article in the Microsoft Knowledge Base:
2962409 Windows RT 8.1, Windows 8.1, and Windows Server 2012 R2 update rollup: June 2014

Hotfix information

A supported hotfix is available from Microsoft Support. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, go to the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Service Pack 1 for Windows 7 or Windows Server 2008 R2 installed.



Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any previously released hotfix.

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File information
The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

Windows 7 and Windows Server 2008 R2 file information and notes

Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows 7 and Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
Ocsp.mscNot Applicable92,55405-Nov-201002:14Not Applicable
Ocspadminnative.dll5.2.3790.1289252,92811-Apr-201402:08x86
For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Ocsp.mscNot Applicable92,55405-Nov-201002:15Not Applicable
Ocspadminnative.dll5.2.3790.1289250,36811-Apr-201402:29x64

Additional file information

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7
File namePackage_1_for_kb2950080~31bf3856ad364e35~x86~~6.1.1.0.mum
File versionNot Applicable
File size1,854
Date (UTC)11-Apr-2014
Time (UTC)06:39
PlatformNot Applicable
File namePackage_for_kb2950080_sp1~31bf3856ad364e35~x86~~6.1.1.0.mum
File versionNot Applicable
File size1,463
Date (UTC)11-Apr-2014
Time (UTC)06:39
PlatformNot Applicable
File nameX86_c68cabab32d80a96d880e44a8a1dd3b1_31bf3856ad364e35_6.1.7601.22652_none_aeed24f864801530.manifest
File versionNot Applicable
File size727
Date (UTC)11-Apr-2014
Time (UTC)06:39
PlatformNot Applicable
File nameX86_microsoft-windows-c..ocspadminnative-dll_31bf3856ad364e35_6.1.7601.22652_none_0e44d26a8322f5b8.manifest
File versionNot Applicable
File size13,000
Date (UTC)11-Apr-2014
Time (UTC)02:36
PlatformNot Applicable
Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameAmd64_20e14e0f81756702d2bc0f86a6235550_31bf3856ad364e35_6.1.7601.22652_none_450b5ba07e9ece08.manifest
File versionNot Applicable
File size731
Date (UTC)11-Apr-2014
Time (UTC)06:39
PlatformNot Applicable
File nameAmd64_microsoft-windows-c..ocspadminnative-dll_31bf3856ad364e35_6.1.7601.22652_none_6a636dee3b8066ee.manifest
File versionNot Applicable
File size13,004
Date (UTC)11-Apr-2014
Time (UTC)03:03
PlatformNot Applicable
File namePackage_1_for_kb2950080~31bf3856ad364e35~amd64~~6.1.1.0.mum
File versionNot Applicable
File size2,070
Date (UTC)11-Apr-2014
Time (UTC)06:39
PlatformNot Applicable
File namePackage_for_kb2950080_sp1~31bf3856ad364e35~amd64~~6.1.1.0.mum
File versionNot Applicable
File size1,677
Date (UTC)11-Apr-2014
Time (UTC)06:39
PlatformNot Applicable

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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References

Learn about the terminology that Microsoft uses to describe software updates.

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Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbexpertiseinter, kbsurveynew, kbbug

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Article Info
Article ID : 2950080
Revision : 1
Created on : 1/7/2017
Published on : 6/10/2014
Exists online : False
Views : 405