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Cannot connect to remote applications hosted on a Windows Server 2012 R2 or Windows Server 2008 R2 SP1-based computer


View products that this article applies to.

Symptoms

Users randomly fail to connect to the remote applications that are hosted on a Windows Server 2012 R2 or Windows Server 2008 R2 Service Pack 1 (SP1)-based computer.

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Cause

This issue occurs because of a deadlock in Windows Management Instrumentation (WMI).

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Resolution

To resolve this issue in Windows Server 2012 R2, install update 2955164. For more information about update 2955164, click the following article number to view the article in the Microsoft Knowledge Base:
2955164 Windows RT 8.1, Windows 8.1, and Windows Server 2012 R2 update rollup: May 2014
To resolve this issue in Windows Server 2008 R2, install the hotfix that is described in this article.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website:
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 R2 SP1.

For more information about how to obtain a Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You may be prompted to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.
File information
Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    VersionProductMilestoneService branch
    6.1.760 1.22xxxWindows Server 2008 R2SP1LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Tscfgwmi.dll6.1.7601.22610198,14425-Feb-201402:33x64
Tscfgwmi.dll6.1.7601.22610155,13625-Feb-201406:07x86
For all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Tscfgwmi.dll6.1.7601.22610450,56025-Feb-201401:42IA-64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684
Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2
File propertyValue
File nameAmd64_92f2856b2bccb67615a9f9e44a283fe3_31bf3856ad364e35_6.1.7601.22610_none_0e6bcff03f6552a6.manifest
File versionNot applicable
File size720
Date (UTC)25-Feb-2014
Time (UTC)14:07
PlatformNot applicable
File nameAmd64_fc0e3ab09b27b767103680a6d35563ff_31bf3856ad364e35_6.1.7601.22610_none_f3a9da0098de4636.manifest
File versionNot applicable
File size718
Date (UTC)25-Feb-2014
Time (UTC)14:07
PlatformNot applicable
File nameAmd64_microsoft-windows-t..ervices-wmiprovider_31bf3856ad364e35_6.1.7601.22610_none_49dd1c5faec224cf.manifest
File versionNot applicable
File size17,000
Date (UTC)25-Feb-2014
Time (UTC)06:24
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size2,489
Date (UTC)25-Feb-2014
Time (UTC)14:07
PlatformNot applicable
File nameX86_microsoft-windows-t..ervices-wmiprovider_31bf3856ad364e35_6.1.7601.22610_none_edbe80dbf664b399.manifest
File versionNot applicable
File size16,996
Date (UTC)25-Feb-2014
Time (UTC)06:37
PlatformNot applicable
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
File propertyValue
File nameIa64_2f807b9144e0b0948a87935a1b9d1d2d_31bf3856ad364e35_6.1.7601.22610_none_77e0d9ce3d3c0995.manifest
File versionNot applicable
File size718
Date (UTC)25-Feb-2014
Time (UTC)14:07
PlatformNot applicable
File nameIa64_microsoft-windows-t..ervices-wmiprovider_31bf3856ad364e35_6.1.7601.22610_none_edc024d1f662bc95.manifest
File versionNot applicable
File size16,998
Date (UTC)25-Feb-2014
Time (UTC)06:23
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size1,452
Date (UTC)25-Feb-2014
Time (UTC)14:07
PlatformNot applicable



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Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseadvanced

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Article Info
Article ID : 2928492
Revision : 1
Created on : 1/7/2017
Published on : 5/13/2014
Exists online : False
Views : 323