Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

The W3wp.exe process randomly stops and causes all sessions to disconnect in Forefront Unified Access Gateway 2010


View products that this article applies to.

Symptoms

On a server that is running Microsoft Forefront Unified Access Gateway 2010, the W3wp.exe process may randomly stop and cause all sessions to disconnect. When this occurs, you receive the following error message:

A process serving application pool 'DefaultAppPool' suffered a fatal communication error with the Windows Process Activation Service. The process id was 'process_id'. The data field contains the error number.

Additionally, an error message is logged in the Application event section of the Windows Logs event log that resembles the following:


↑ Back to the top


Cause

This problem occurs because of an access violation (Exception code: 0xc0000005) in the worker process. This occurs because of an invalid pointer.

↑ Back to the top


Resolution

To resolve this problem, install Service Pack 4 for Microsoft Forefront Unified Access Gateway 2010.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


References

See the terminology Microsoft uses to describe software updates.

↑ Back to the top


Keywords: kbqfe, kbfix, kbexpertiseinter, kbsurveynew, kbbug, kbnotautohotfix, kb

↑ Back to the top

Article Info
Article ID : 2909168
Revision : 1
Created on : 1/7/2017
Published on : 11/27/2013
Exists online : False
Views : 295