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"0x0000009E" Stop error on cluster nodes in a Windows Server-based multi-node failover cluster environment


View products that this article applies to.

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Symptoms

Assume that you have a Windows Server 2008 R2 Service Pack 1 (SP1) or Windows Server 2012-based multi-node failover cluster that uses the Microsoft Device Specific Module (MSDSM) and Microsoft Multipath I/O (MPIO). The following events occur at almost the same time:
  • A new instance of an existing device arrives. Specifically, a new path to an MPIO disk is generated.
  • MSDSM finishes an I/O request. The request was the last outstanding I/O request.
In this scenario, some cluster nodes crash. Additionally, you receive a Stop error message that resembles the following:
STOP: 0x0000009E (parameter1, parameter2, parameter3, parameter4)
Notes
  • This Stop error describes an USER_MODE_HEALTH_MONITOR issue.
  • The parameters in this Stop error message vary, depending on the configuration of the computer.
  • Not all "Stop 0x0000009E" errors are caused by this issue.

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Cause

This issue occurs because a remove lock on a logical unit number (LUN) is obtained two times, but only released one time. Therefore, the Plug and Play (PnP) manager cannot remove the device, and then the node crashes.

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Resolution

Update rollup information

To resolve this issue in Windows Server 2012, install update rollup 2911101. For more information about how to obtain this update rollup package, click the following article number to view the article in the Microsoft Knowledge Base:
2911101 Windows RT, Windows 8, and Windows Server 2012 update rollup: January 2014

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 R2 SP1 or Windows Server 2012.

For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.
File information
The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    VersionProductMilestoneService branch
    6.1.760
    1.18xxx
    Windows Server 2008 R2SP1GDR
    6.1.760
    1.22xxx
    Windows Server 2008 R2SP1LDR
  • GDR service branches contain only those fixes that are widely released to address widespread, critical issues. LDR service branches contain hotfixes in addition to widely released fixes.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Mpio.sys6.1.7601.18251159,16804-Sep-201313:00x64
Mpio.sys6.1.7601.22441160,70404-Sep-201302:28x64
For all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Mpio.sys6.1.7601.18251357,31204-Sep-201301:29IA-64
Mpio.sys6.1.7601.22441366,01604-Sep-201301:38IA-64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2
File propertyValue
File nameAmd64_mpio.inf_31bf3856ad364e35_6.1.7601.18251_none_7b2a8502a6170f9a.manifest
File versionNot applicable
File size2,073
Date (UTC)04-Sep-2013
Time (UTC)13:26
PlatformNot applicable
File nameAmd64_mpio.inf_31bf3856ad364e35_6.1.7601.22441_none_7bbef39fbf2c909a.manifest
File versionNot applicable
File size2,073
Date (UTC)04-Sep-2013
Time (UTC)02:54
PlatformNot applicable
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
File propertyValue
File nameIa64_mpio.inf_31bf3856ad364e35_6.1.7601.18251_none_1f0d8d74edb7a760.manifest
File versionNot applicable
File size2,071
Date (UTC)04-Sep-2013
Time (UTC)02:11
PlatformNot applicable
File nameIa64_mpio.inf_31bf3856ad364e35_6.1.7601.22441_none_1fa1fc1206cd2860.manifest
File versionNot applicable
File size2,071
Date (UTC)04-Sep-2013
Time (UTC)02:19
PlatformNot applicable

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Keywords: kb, kbmdd, kbqfe, kbautohotfix, kbhotfixserver, kbsurveynew, kbexpertiseadvanced, kbfix

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Article Info
Article ID : 2876391
Revision : 1
Created on : 1/7/2017
Published on : 10/9/2014
Exists online : False
Views : 363