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The Physical Disk resource for a Cluster Shared Volume may not come online during backup


View products that this article applies to.

Important The hotfix that corresponds to KB 2869923 has been included with the hotfix KB 2878635, which contains all fixes that were previously included in KB 2869923.

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Symptoms

Consider the following scenario:

  • You configure a Windows Server 2012-based Hyper-V failover cluster that uses Cluster Shared Volumes (CSV).
  • The VHD or VHDX files reside on the Cluster Shared Volume.
  • Backups of the Cluster Shared Volume are performed by using software snapshots.
  • The Physical Disk resource for the Cluster Shared Volume is moved to another node in the cluster.
In this scenario, the Physical Disk resource may not come online if the backup of the Cluster Shared Volume is in progress. Therefore, virtual machines that rely on the Cluster Shared Volume may crash. Additionally, the following event is logged in the System log:

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Cause

During a move of the Physical Disk resource, when the Physical Disk resource comes online on the new node, the Physical Disk resource queries the Volume Shadow Copy Service (VSS) to discover the software snapshots that are associated with that volume. If the move occurs while software snapshots are in progress, VSS may not respond or may take a long time to respond. Ultimately, this may cause the Physical Disk resource to either not come online or take a long time to come online on the new node. Therefore, virtual machines that have VHD files on the Cluster Shared Volume may crash.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, go to the following Microsoft website: Note The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2012.

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

The hotfix that corresponds to KB 2869923 has been included with the hotfix KB 2878635, which contains all fixes that were previously included in KB 2869923. You should use the hotfix KB 2878635 to fix the issues described in KB 2869923. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
2878635 Update is available that improves the resiliency of the cloud service provider in Windows Server 2012: December 2013
File information
The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.





Windows Server 2012 file information notes
Important Windows 8 hotfixes and Windows Server 2012 hotfixes are included in the same packages. However, only "Windows 8" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 8" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:

    VersionProductMilestoneService branch
    6.2.920 0.20 xxxWindows Server 2012RTMLDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2012" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2012
File nameFile versionFile sizeDateTimePlatform
Clussvc.exe6.2.9200.207677,228,92809-Jul-201307:01x64
Csvfs.sys6.2.9200.20767625,66409-Jul-201305:40x64
Vhdmp.sys6.2.9200.20767496,46409-Jul-201308:22x64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
Additional file information

Additional file information for Windows Server 2012

Additional files for all supported x64-based versions of Windows Server 2012
File nameAmd64_76fdbc133f3ed82d90ff789f9753abe4_31bf3856ad364e35_6.2.9200.20767_none_8863ee901f01e8ce.manifest
File versionNot Applicable
File size1,072
Date (UTC)09-Jul-2013
Time (UTC)22:30
PlatformNot Applicable
File nameAmd64_ba07f0fa8f291d3409cb3d5149977a65_31bf3856ad364e35_6.2.9200.20767_none_6407415c8468b205.manifest
File versionNot Applicable
File size718
Date (UTC)09-Jul-2013
Time (UTC)22:30
PlatformNot Applicable
File nameAmd64_microsoft-windows-f..overcluster-clussvc_31bf3856ad364e35_6.2.9200.20767_none_132d93e5445aaef9.manifest
File versionNot Applicable
File size10,086
Date (UTC)09-Jul-2013
Time (UTC)08:16
PlatformNot Applicable
File nameAmd64_microsoft-windows-f..rcluster-csvfs-core_31bf3856ad364e35_6.2.9200.20767_none_2fa2c0d7023ca99b.manifest
File versionNot Applicable
File size3,087
Date (UTC)09-Jul-2013
Time (UTC)08:15
PlatformNot Applicable
File nameAmd64_vhdmp.inf_31bf3856ad364e35_6.2.9200.20767_none_fffc48ff6c6c2eb3.manifest
File versionNot Applicable
File size2,096
Date (UTC)09-Jul-2013
Time (UTC)09:12
PlatformNot Applicable
File nameUpdate.mum
File versionNot Applicable
File size2,003
Date (UTC)09-Jul-2013
Time (UTC)22:30
PlatformNot Applicable
File nameWow64_microsoft-windows-f..overcluster-clussvc_31bf3856ad364e35_6.2.9200.20767_none_1d823e3778bb70f4.manifest
File versionNot Applicable
File size6,868
Date (UTC)09-Jul-2013
Time (UTC)04:30
PlatformNot Applicable

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Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew

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Article Info
Article ID : 2869923
Revision : 1
Created on : 1/7/2017
Published on : 1/13/2014
Exists online : False
Views : 264