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Synchronization process fails when you use EAS to connect to a mailbox in Exchange Server 2010


View products that this article applies to.

Symptoms

Consider the following scenario:
  • Update Rollup 6 for Microsoft Exchange Server 2010 Service Pack 2 (SP2) or a later update rollup is installed in an environment that contains multiple Active Directory sites.
  • The sites have Internet-facing Client Access servers.
  • Internal and external URLs are configured on the Internet-facing Client Access servers.
  • You try to synchronize a device to a mailbox by using Microsoft Exchange ActiveSync (EAS).
  • The device sends EAS requests to a Client Access server that is not in the Active Directory site on which the Mailbox server is located.
In this scenario, the device retrieves an HTTP 403 redirect response instead of the expected HTTP 451 redirect response. Then, the synchronization process fails.

Additionally, the following event is logged in the Application log:

Log Name:      Application Source:        MSExchange ActiveSync Date:           Date and Time Event ID:      1044 Task Category: Requests Level:         Warning Keywords:      Classic User:          N/A Computer:       COMPUTER Description: The Client Access server doesn't have the InternalURL value set for the Microsoft-Server-ActiveSync virtual directory. This prevents Exchange ServiceDiscovery from finding the MobileSyncService information for user  MBX server . At least one Client Access server in the user's mailbox Active Directory site must have the InternalURL value set. The format for the InternalURL value is https://hostname/Microsoft-Server-ActiveSync 


Notes

  • If this issue occurs in an on-premises-only installation of Exchange Server 2010, an entry is logged in the Internet Information Services (IIS) log files. The following is a sample of this entry: 

    Date Time 214.21.84.142 POST /Microsoft-Server-ActiveSync/default.eas Cmd=Provision&DeviceType=DeviceType&User=user1 &DeviceId=DeviceId&Log=RdirTo:https%3a%2f%2fmail-eu.contoso.coml%2fMicrosoft-Server-ActiveSync_V25_LdapC1_Cpo19984_Fet20015_S130_Error:DiscoveryInfoMissing_Mbx:mbx1.contoso.com_Budget:(D)Conn%3a1%2cHangingConn%3a0%2cAD%3a%24null%2f%24null%2f0%25%2cCAS%3a%24null%2f%24null%2f0%25%2cAB%3a%24null%2f%24null%2f0%25%2cRPC%3a%24null%2f%24null%2f0%25%2cFC%3a%24null%2f0%2cPolicy%3aDefaultThrottlingPolicy%2cNorm_ 443 contoso\user1 192.168.0.20 UserAgent - 403 0 0 1477 523 20046
  • You can use the following Log Parser Studio query to identify which users are affected when this issue occurs:
    SELECT COUNT(*) AS Hits, cs-username AS User
    FROM '[LOGFILEPATH]' WHERE cs-uri-query LIKE '%DiscoveryInfoMissing%'
    GROUP BY User
    ORDER BY Hits DESC


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Cause

This issue occurs on Android and Windows Phone 8 devices because the list of device types and models that is validated by the DeviceCapability.RedirectDeviceTypes structure does not contain the type and model of your device. 

This issue occurs on Apple iOS devices because requests from iOS devices do not contain EAS version information or the device string. Therefore, the DeviceCapability function does not redirect the request.

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Resolution

To resolve this issue, install the following update rollup:
2866475 Description of Update Rollup 2 for Exchange Server 2010 SP3

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about this issue, click the following article numbers to view the articles in the Microsoft Knowledge Base:
2746164 Description of Update Rollup 6 for Exchange Server 2010 Service Pack 2
2751417 Synchronization fails if you sync an external device to a mailbox through EAS in an Exchange Server 2010 environment
For more information about Log Parser Studio, go to the following Microsoft website:
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

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Keywords: kbqfe, kbfix, kbsurveynew, kbexpertiseinter, kb

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Article Info
Article ID : 2850143
Revision : 1
Created on : 1/7/2017
Published on : 10/10/2013
Exists online : False
Views : 402