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I/O operations time out for files that are stored on offline storage in Windows 8 and Windows Server 2012


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a Windows 8-based or Windows Server 2012-based Server Message Block (SMB) server that uses removable storage (such as a tape library) as a file share.
  • You have a client computer that connects to the SMB server by using the SMB3 protocol.
  • You try to perform an I/O operation on files that are stored on a tape which is not loaded. The files have the FILE_ATTRIBUTE_OFFLINE attribute set.
In this scenario, the I/O operation times out.

Note A similar issue occurs in Windows 7 and Windows Server 2008 R2. For more information, see 2848321 .

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Cause

The issue occurs because SMB3 does not recognize the FILE_ATTRIBUTE_OFFLINE attribute. When the request expiration timer expires before the tape is loaded, the I/O operation times out.

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Resolution

This hotfix is also available at Microsoft Update Catalog.

To resolve the issue, apply the hotfix on the SMB server. After you apply the hotfix, the I/O operations are processed asynchronously. You must modify the ExtendedSessTimeout registry entry on the SMB client to extend time-out for asynchronous requests. Additionally, we recommend that you increase the value of the AsynchronousCredits registry entry on the SMB server. For more information, see the Registry information section.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows 8 or Windows Server 2012.

Registry information

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows
To modify the ExtendedSessTimeout registry entry on the SMB client, follow these steps:
  1. Start Registry Editor.
  2. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters
  3. In the details pane, double-click the ExtendedSessTimeout entry.
  4. In the Value data box, enter the time-out period for asynchronous operations.

    Type: DWORD
    Value: time-delay in seconds
    Default value: 240

 If the ExtendedSessTimeout registry entry does not exist, create it. You may start by doubling the default value.

To modify the AsynchronousCredits registry entry on the SMB server to which this hotfix has been applied, follow these steps:
  1. Start Registry Editor.
  2. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Lanmanserver\Parameters
  3. In the details pane, double-click the AsynchronousCredits entry.
  4. In the Value data box, enter the maximum number of concurrent asynchronous operations.
The value type of this entry is REG_DWORD. The value data of this entry is decimal, and is the maximum number of concurrent SMB requests. If the AsynchronousCredits registry entry does not exist, create it. The default value is 512. This parameter limits the number of concurrent asynchronous SMB commands that are allowed on a single connection. Some file clients such as IIS servers require a large amount of concurrency, particularly with file change notification requests. The value of this entry can be increased to support these clients. You may start by doubling the default value.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.
File information
The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 8 and Windows Server 2012 file information notes
Important Windows 8 and Windows Server 2012 hotfixes are included in the same packages. However, only "Windows 8" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 8" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, milestone (RTM,SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    VersionProductMilestoneService branch
    6.2.920 0.20 xxxWindows 8 and Windows Server 2012RTMLDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows 8 and Windows Server 2012" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 8
File nameFile versionFile sizeDateTimePlatform
Srv2.sys6.2.9200.20741494,59210-Jun-201323:13x86
For all supported x64-based versions of Windows 8 and of Windows Server 2012
File nameFile versionFile sizeDateTimePlatform
Srv2.sys6.2.9200.20741619,52011-Jun-201305:22x64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about the FILE_ATTRIBUTE_OFFLINE attribute, see File Attribute Constants.

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows 8 and for Windows Server 2012

Additional files for all supported x86-based versions of Windows 8
File nameUpdate.mum
File versionNot Applicable
File size1,594
Date (UTC)11-Jun-2013
Time (UTC)14:56
PlatformNot Applicable
File nameX86_c6f0e45e18703b7a0c8eeaf8896161bd_31bf3856ad364e35_6.2.9200.20741_none_9046e7b69bd5c5cc.manifest
File versionNot Applicable
File size700
Date (UTC)11-Jun-2013
Time (UTC)14:56
PlatformNot Applicable
File nameX86_microsoft-windows-smbserver-v2_31bf3856ad364e35_6.2.9200.20741_none_d749869ee0e253fd.manifest
File versionNot Applicable
File size207,155
Date (UTC)11-Jun-2013
Time (UTC)00:59
PlatformNot Applicable
Additional files for all supported x64-based versions of Windows 8 and of Windows Server 2012
File nameAmd64_e0ea752a1d202b16f3f1bffc63257d50_31bf3856ad364e35_6.2.9200.20741_none_ce59f7b41fc3163b.manifest
File versionNot Applicable
File size704
Date (UTC)11-Jun-2013
Time (UTC)14:35
PlatformNot Applicable
File nameAmd64_microsoft-windows-smbserver-v2_31bf3856ad364e35_6.2.9200.20741_none_33682222993fc533.manifest
File versionNot Applicable
File size207,159
Date (UTC)11-Jun-2013
Time (UTC)07:21
PlatformNot Applicable
File nameUpdate.mum
File versionNot Applicable
File size1,602
Date (UTC)11-Jun-2013
Time (UTC)14:35
PlatformNot Applicable

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Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseadvanced

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Article Info
Article ID : 2848322
Revision : 1
Created on : 1/7/2017
Published on : 10/21/2013
Exists online : False
Views : 238