Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Cached credentials are not updated when you change your password in Windows


View products that this article applies to.

Symptoms

Consider the following scenario:
  • In an Active Directory domain environment, you have a user account.
  • The user principal name (UPN) of the account differs from the Security Accounts Manager (SAM) name of the account. For example, the UPN of the account resembles "username@domain.com," and the SAM name of the account resembles "domain\username2."
  • The credentials are cached on a client computer that is running Windows 8, Windows Server 2012, Windows 7 Service Pack 1 (SP1), or Windows Server 2008 R2 SP1.
  • You always log on to the client computer by using the UPN method.
  • You change the password of the user account by using the client computer. For example, you press Ctrl+Alt+Del and then click Change Password.

In this scenario, your credentials that are cached in the Local Security Authentication Server (Lsass.exe) process are not updated.

Note You are prompted to enter credentials to continue accessing network resources because of this problem.

↑ Back to the top


Cause

This problem occurs because the Kerberos.dll file tries to compare the password change in the UPN user name format and in the SAM user name format in the Kerberos logon session. Because the UPN and the SAM name are different in this case, the credentials in the Lsass.exe process are not updated.

↑ Back to the top


Resolution

Update information for Windows 8 and Windows Server 2012

To resolve this issue in Windows 8 or Windows Server 2012, install the update rollup 2883201. For more information about how to obtain this update rollup package, click the following article number to go to the article in the Microsoft Knowledge Base:

2883201 Windows RT, Windows 8, and Windows Server 2012 update rollup: October 2013

Hotfix information for Windows 7 and Windows Server 2008 R2

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, go to the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running one of the following operating systems:

  • Windows 7 Service Pack 1 (SP1)
  • Windows Server 2008 R2 Service Pack 1 (SP1)

For information about how to obtain a Windows 7 or a Windows Server 2008 R2 service pack, see Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2 .

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information
The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

Windows 7 and Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.

    VersionProductSR_LevelService branch
    6.1.760
    1.
    22xxx
    Windows 7 and Windows Server 2008 R2SP1LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows 7 and Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
Kerberos.dll6.1.7601.22320543,23209-May-201315:00x86
For all supported x64-based versions of Windows 7 and Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Kerberos.dll6.1.7601.22320716,80009-May-201316:48x64
Kerberos.dll6.1.7601.22320543,23209-May-201315:00x86
For all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Kerberos.dll6.1.7601.223201,500,67209-May-201314:06IA-64
Kerberos.dll6.1.7601.22320543,23209-May-201315:00x86

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


Additional file information

Additional file information for Windows 7 and Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7
File nameX86_105464f0bcefff5c823c85ef7e2a6145_31bf3856ad364e35_6.1.7601.22320_none_577025fde8de9e12.manifest
File versionNot applicable
File size705
Date (UTC)09-May-2013
Time (UTC)22:15
PlatformNot applicable
File nameX86_microsoft-windows-security-kerberos_31bf3856ad364e35_6.1.7601.22320_none_e958f6542839218e.manifest
File versionNot applicable
File size33,218
Date (UTC)09-May-2013
Time (UTC)15:31
PlatformNot applicable
Additional files for all supported x64-based versions of Windows 7 and Windows Server 2008 R2
File nameAmd64_630fbf298ccd270a69b3b6436c50bdab_31bf3856ad364e35_6.1.7601.22320_none_1a8c4b651db1eb5b.manifest
File versionNot applicable
File size709
Date (UTC)09-May-2013
Time (UTC)22:15
PlatformNot applicable
File nameAmd64_dc6f8c55832a2063a19bd37139ef1db0_31bf3856ad364e35_6.1.7601.22320_none_eb85560a53ca7ec6.manifest
File versionNot applicable
File size1,060
Date (UTC)09-May-2013
Time (UTC)22:15
PlatformNot applicable
File nameAmd64_microsoft-windows-security-kerberos_31bf3856ad364e35_6.1.7601.22320_none_457791d7e09692c4.manifest
File versionNot applicable
File size33,222
Date (UTC)09-May-2013
Time (UTC)17:21
PlatformNot applicable
File nameWow64_microsoft-windows-security-kerberos_31bf3856ad364e35_6.1.7601.22320_none_4fcc3c2a14f754bf.manifest
File versionNot applicable
File size22,967
Date (UTC)09-May-2013
Time (UTC)15:17
PlatformNot applicable
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
File nameIa64_076d0f4bdda7660ed79792a959875a7b_31bf3856ad364e35_6.1.7601.22320_none_8b6b2d94028ecce7.manifest
File versionNot applicable
File size1,058
Date (UTC)09-May-2013
Time (UTC)22:15
PlatformNot applicable
File nameIa64_microsoft-windows-security-kerberos_31bf3856ad364e35_6.1.7601.22320_none_e95a9a4a28372a8a.manifest
File versionNot applicable
File size33,220
Date (UTC)09-May-2013
Time (UTC)15:26
PlatformNot applicable
File nameWow64_microsoft-windows-security-kerberos_31bf3856ad364e35_6.1.7601.22320_none_4fcc3c2a14f754bf.manifest
File versionNot applicable
File size22,967
Date (UTC)09-May-2013
Time (UTC)15:17
PlatformNot applicable

↑ Back to the top


Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbexpertiseinter, kbsurveynew, kbbug

↑ Back to the top

Article Info
Article ID : 2845626
Revision : 1
Created on : 1/7/2017
Published on : 10/9/2013
Exists online : False
Views : 354