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Shared Nothing Live Migration fails when you try to migrate a virtual machine to a destination server in Windows Server 2012


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You install the Hyper-V role on a source server and destination server that are running Windows Server 2012.
  • You create a virtual machine (vm1) on the source server.
  • You create two virtual hard disk (VHD) files for the virtual machine. One of the VHD files is larger than drive C on the destination server. For example, you create a 1 gigabyte (GB) VHD file and a 50 GB VHD file, and drive C is smaller than 50 GB.
  • You try to perform a Shared Nothing Live Migration to migrate the virtual machine to the destination server. More specifically, you try to migrate the VHD files as follows:
    • You try to migrate the smaller VHD file to the network share that maps to local drive C. Drive C has limited available space. For example, the available space on drive C is 10 GB.
    • You try to migrate the larger VHD file to the network share that maps to local drive D. Drive D has lots of available space. For example, the available space on drive D is 100 GB.
In this scenario, the migration operation fails, and you receive the following error message:
Migration did not succeed. Not enough disk space at \\destination server\share$.

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Cause

This issue occurs because the system checks for available space for the VHD files on only one drive on the destination server. However, the expected behavior is that the system checks for available space on each destination drive.

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Resolution

This hotfix is also available at Microsoft Update Catalog

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2012.

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.
File information
The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.





Windows Server 2012 file information notes
Important Windows 8 hotfixes and Windows Server 2012 hotfixes are included in the same packages. However, only "Windows 8" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 8" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:

    VersionProductMilestoneService branch
    6.2.920 0.16 xxxWindows 8 and Windows Server 2012RTMGDR
    6.2.920 0.20 xxxWindows Server 2012RTMLDR
  • GDR service branches contain only those fixes that are widely released to address widespread, extremely important issues. LDR service branches contain hotfixes in addition to widely released fixes.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2012" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2012
File nameFile versionFile sizeDateTimePlatform
Vmms.exe6.2.9200.1661011,201,02411-May-201304:08x64
Vmms.exe6.2.9200.2071411,201,02411-May-201304:14x64


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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
Additional file information

Additional file information for Windows Server 2012

Additional files for all supported x64-based versions of Windows Server 2012
File nameAmd64_microsoft-hyper-v-vstack-vmms_31bf3856ad364e35_6.2.9200.16610_none_8fa76302e87bba35.manifest
File versionNot applicable
File size1,134,338
Date (UTC)13-May-2013
Time (UTC)21:29
PlatformNot applicable
File nameAmd64_microsoft-hyper-v-vstack-vmms_31bf3856ad364e35_6.2.9200.20714_none_903500f60195bf5b.manifest
File versionNot applicable
File size1,134,338
Date (UTC)13-May-2013
Time (UTC)21:29
PlatformNot applicable

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Keywords: kberrmsg, kbexpertiseadvanced, kbsurveynew, kbautohotfix, kbhotfixserver, kbqfe, kb, kbfix

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Article Info
Article ID : 2844296
Revision : 1
Created on : 1/7/2017
Published on : 6/13/2013
Exists online : False
Views : 241