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Delayed email message delivery on a BlackBerry mobile device after you install Update Rollup 4 for Exchange Server 2010 SP2


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You install Update Rollup 4 for Microsoft Exchange Server 2010 SP2 on an Exchange Server 2010 SP2 server that is running against a BlackBerry Enterprise Server.
  • The BlackBerry Enterprise Server uses MAPI or Collaborative Data Objects (CDO) instead of Exchange Web Services (EWS) to communicate with Exchange servers.
  • A mailbox on a BlackBerry mobile device contains many folders. For example, the mailbox contains more than 5000 folders.
In this scenario, you encounter one or more of the following issues:
  • Delivery of email messages to a mailbox on a BlackBerry mobile device is delayed.
  • It takes longer than expected to scan a folder hierarchy in the mailbox. For example, before you install Update Rollup 4 for Exchange Server 2010 SP2, a scan of a folder hierarchy takes about 5 minutes. After you install Update Rollup 4 for Exchange Server 2010 SP2, a scan of a folder hierarchy takes about 30 minutes to 1 hour.
  • The Microsoft Exchange Information Store process (Store.exe) on the Exchange Mailbox server consumes too many CPU resources.
  • Some BlackBerry Enterprise Server event log entries are logged on the Exchange Mailbox server. Before you install Update Rollup 4 for Exchange Server 2010 SP2, few entries are logged, or no entries are logged.
  • Some events are logged in the BlackBerry Messaging Agent (MAGT) log. These events resemble "Busy Working" threads that are described in the following article in the BlackBerry Knowledge Base:



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Cause

This issue occurs because the Exchange server creates a new administrator session every time the server tries to bind a delegate to each folder and retrieve folder properties for the delegate. Additionally, because the server sets a certain flag for each folder bind, a high-cost process flow occurs. Therefore, when BlackBerry Enterprise Server requests the properties of many folders, the issue that is described in the "Symptoms" section occurs.

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Resolution

To resolve this issue, install the following update rollup:
2803727 Description of Update Rollup 1 for Exchange Server 2010 Service Pack 3

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about the issue, click the following article numbers to view the articles in the Microsoft Knowledge Base:
2726897 Admin sessions are exhausted as a result of delegate access in an Exchange Server 2010 environment
2706690 Description of Update Rollup 4 for Exchange Server 2010 Service Pack 2
2797529 Email message delivery is delayed on a Blackberry mobile device after you install Update Rollup 4 for Exchange Server 2010 SP2
2810616 Email message delivery is delayed on a Blackberry mobile device after you install Update Rollup 4 for Exchange Server 2010 SP2

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

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Keywords: kbqfe, kbfix, kbsurveynew, kbexpertiseinter, kb

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Article Info
Article ID : 2803132
Revision : 1
Created on : 1/7/2017
Published on : 5/30/2013
Exists online : False
Views : 387