Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Virtual machine enters a paused state or a CSV volume goes offline when you try to create a backup of the virtual machine on a Windows Server 2012-based failover cluster


View products that this article applies to.

Important The hotfix that corresponds to KB 2799728 has been included with the hotfix KB 2878635, which contains all fixes that were previously included in KB 2799728.

↑ Back to the top


Symptoms

Consider the following scenario:
  • You enable the Cluster Shared Volumes (CSV) feature on a Windows Server 2012-based failover cluster.
  • You create a virtual machine on a CSV volume on a cluster node.
  • You start the virtual machine.
  • You try to create a backup of the virtual machine on the CSV volume by using Microsoft System Center Data Protection Manager (DPM).
In this scenario, one of the following issues occurs:
  • The backup is created, and the virtual machine enters a paused state.
  • The CSV volume goes offline. Therefore, the virtual machine goes offline, and the backup is not created.
Additionally, the following events are logged in the Cluster log and System log respectively:



Note This issue also occurs when you try to create a snapshot of the virtual machine by using backup software that uses the Microsoft Software Shadow Copy Provider.

↑ Back to the top


Cause

The virtual machine enters a paused state because the Ntfs.sys driver incorrectly reports the available space on the CSV volume when the backup software tries to create a snapshot of the CSV volume. Additionally, the CSV volume goes offline because it does not resume from a paused state after an I/O delay issue or error occurs.

Note The CSV volume is resilient.

↑ Back to the top


Resolution

Hotfix Replacement Information

The hotfix that corresponds to KB 2799728 has been superseded with the hotfix KB 2878635, which contains all fixes that were previously included in KB 2799728. You should use the hotfix KB 2878635 to fix the issues described in KB 2799728. For more information, click the following article number to view the article in the Microsoft Knowledge Base:  
2878635  Update is available that improves the resiliency of the cloud service provider in Windows Server 2012: December 2013  

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


Keywords: kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseadvanced, kb

↑ Back to the top

Article Info
Article ID : 2799728
Revision : 1
Created on : 1/7/2017
Published on : 1/10/2014
Exists online : False
Views : 320