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You cannot scan data by using a USB 3.0 scanner that is connected to a Windows 7 or Windows Server 2008 R2-based computer


View products that this article applies to.

Symptoms

Assume that you have a USB 3.0 scanner that is attached to a computer that is running Windows 7 or Windows Server 2008 R2. In this situation, you cannot scan any data.

Notes

When you try to scan some data, the Windows Image Acquisition (WIA) driver calls the WriteFile() function. However, the Usbscan.sys driver returns the following error message: 
ERROR_INVALID_PARAMETER
  • When you try to scan some data, the Windows Image Acquisition (WIA) driver calls the WriteFile() function. However, the Usbscan.sys driver returns the following error message:
    ERROR_INVALID_PARAMETER
  • If you experience this issue in Windows 8 or in Windows Server 2012, install the update that is described in the following Microsoft Knowledge Base (KB) article:
    2770917 Windows 8 and Windows Server 2012 update rollup: November 2012

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Cause

This issue occurs because the Usbscan.sys driver incorrectly handles the endpoint descriptor.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running one of the following operating systems:
  • Windows 7
  • Windows 7 Service Pack 1 (SP1)
  • Windows Server 2008 R2
  • Windows Server 2008 R2 Service Pack 1 (SP1)
For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.
File information
The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 and Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    VersionProductMilestoneService branch
    6.1.760
    0.16xxx
    Windows 7 and Windows Server2008 R2RTMGDR
    6.1.760 1.18xxxWindows 7 and Windows Server 2008 R2SP1GDR
    6.1.760
    1.22xxx
    Windows 7 and Windows Server 2008 R2SP1LDR
  • GDR service branches contain only those fixes that are widely released to address widespread, critical issues. LDR service branches contain hotfixes in addition to widely released fixes.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows 7 and for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
Scsiscan.sys6.1.7600.1638514,84814-Jul-200900:14x86
Serscan.sys6.1.7600.163859,21614-Jul-200900:14x86
Usbscan.sys6.1.7601.1818036,35211-Jun-201303:53x86
Wiafbdrv.dll6.1.7600.1638589,60014-Jul-200901:16x86
Wsdscan.sys6.1.7600.1638520,48014-Jul-200900:14x86
Scsiscan.sys6.1.7600.1638514,84814-Jul-200900:14x86
Serscan.sys6.1.7600.163859,21614-Jul-200900:14x86
Usbscan.sys6.1.7601.2235336,35211-Jun-201304:05x86
Wiafbdrv.dll6.1.7600.1638589,60014-Jul-200901:16x86
Wsdscan.sys6.1.7600.1638520,48014-Jul-200900:14x86
For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Scsiscan.sys6.1.7600.1638517,92014-Jul-200900:35x64
Serscan.sys6.1.7600.1638512,28814-Jul-200900:35x64
Usbscan.sys6.1.7601.1818042,49611-Jun-201304:46x64
Wiafbdrv.dll6.1.7600.16385107,52014-Jul-200901:41x64
Wsdscan.sys6.1.7600.1638525,08814-Jul-200900:35x64
Scsiscan.sys6.1.7600.1638517,92014-Jul-200900:35x64
Serscan.sys6.1.7600.1638512,28814-Jul-200900:35x64
Usbscan.sys6.1.7601.2235342,49611-Jun-201304:22x64
Wiafbdrv.dll6.1.7600.16385107,52014-Jul-200901:41x64
Wsdscan.sys6.1.7600.1638525,08814-Jul-200900:35x64


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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about USB drivers, go to the following Microsoft website: For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
Additional file information

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7
File nameX86_sti.inf_31bf3856ad364e35_6.1.7601.18180_none_5b966c583f453d1e.manifest
File versionNot applicable
File size4,022
Date (UTC)13-Jun-2013
Time (UTC)11:17
PlatformNot applicable
File nameX86_sti.inf_31bf3856ad364e35_6.1.7601.22353_none_5c437bab5847d241.manifest
File versionNot applicable
File size4,022
Date (UTC)13-Jun-2013
Time (UTC)11:17
PlatformNot applicable
Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameAmd64_sti.inf_31bf3856ad364e35_6.1.7601.18180_none_b7b507dbf7a2ae54.manifest
File versionNot applicable
File size4,026
Date (UTC)13-Jun-2013
Time (UTC)11:13
PlatformNot applicable
File nameAmd64_sti.inf_31bf3856ad364e35_6.1.7601.22353_none_b862172f10a54377.manifest
File versionNot applicable
File size4,026
Date (UTC)13-Jun-2013
Time (UTC)11:13
PlatformNot applicable

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Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseadvanced

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Article Info
Article ID : 2770436
Revision : 1
Created on : 1/7/2017
Published on : 7/25/2013
Exists online : False
Views : 193