Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

You cannot connect to the desktop of a Windows 7-based Hyper-V virtual machine by using the Virtual Machine Connection tool in Windows Server 2012


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have the Hyper-V server role installed on a computer that is running Windows Server 2012.
  • You install the Remote Desktop Virtualization Host (RD Virtualization Host) role service on the computer.
  • You create a virtual machine that is running Windows 7 Service Pack 1 (SP1).  
  • You use the Microsoft RemoteFX feature to improve user experience for virtual machines.
  • You start the Windows 7 SP1-based virtual machine, and then you try to connect to the desktop by using the Virtual Machine Connection tool.
In this scenario, the connection attempt is unsuccessful. Additionally, you receive an error message that resembles the following: 
The virtual machine is currently using the RemoteFX 3D video adapter, which is not supported by the Virtual Machine Connection console. Connect to the virtual machine by using Remote Desktop Connection.

↑ Back to the top


Cause

This issue occurs because Windows 7 SP1-based virtual machine is incompatible with the Virtual Machine Connection tool in Windows Server 2012.

↑ Back to the top


Resolution

Hotfix information

To resolve this issue, install the following hotfix package on the Windows 7 SP1-based virtual machine.

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows 7 Service Pack 1 (SP1).

For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    VersionProductMilestoneService branch
    6.1.760
    1.22xxx
    Windows 7 SP1LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows 7" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
Rdvghelper.exe1.1.0.082,94423-Aug-201216:52x86
Sessenv.dll6.1.7601.22098118,27223-Aug-201216:56x86
Rdvgkmd.sys6.1.7601.2209894,57623-Aug-201217:05x86
Rdvgumd32.dll6.1.7601.2209879,21623-Aug-201217:05x86
For all supported x64-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
Rdvghelper.exe1.1.0.097,79223-Aug-201217:51x64
Sessenv.dll6.1.7601.22098126,97623-Aug-201217:58x64
Rdvgkmd.sys6.1.7601.22098115,05623-Aug-201218:07x64
Rdvgumd64.dll6.1.7601.2209899,69623-Aug-201218:07x64
Sessenv.dll6.1.7601.22098118,27223-Aug-201216:56x86

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows 7

Additional files for all supported x86-based versions of Windows 7
File nameX86_2c640340a5b29bf4f9f5d09cdc13f857_31bf3856ad364e35_6.1.7601.22098_none_fee8ececde75ae2d.manifest
File versionNot applicable
File size722
Date (UTC)24-Aug-2012
Time (UTC)19:32
PlatformNot applicable
File nameX86_ab4d0c3f6025bc03aa0494e703eb4cd3_31bf3856ad364e35_6.1.7601.22098_none_d5c0166f54e5834e.manifest
File versionNot applicable
File size729
Date (UTC)24-Aug-2012
Time (UTC)19:32
PlatformNot applicable
File nameX86_microsoft-windows-r..s-regkeys-component_31bf3856ad364e35_6.1.7601.22098_none_fccc761477bf1970.manifest
File versionNot applicable
File size3,961
Date (UTC)23-Aug-2012
Time (UTC)17:30
PlatformNot applicable
File nameX86_microsoft-windows-t..s-sessionenvservice_31bf3856ad364e35_6.1.7601.22098_none_e11cbbe05f44312d.manifest
File versionNot applicable
File size6,602
Date (UTC)23-Aug-2012
Time (UTC)17:27
PlatformNot applicable
File nameX86_rdvgwddm.inf_31bf3856ad364e35_6.1.7601.22098_none_716e16c7cdda8910.manifest
File versionNot applicable
File size2,730
Date (UTC)23-Aug-2012
Time (UTC)17:25
PlatformNot applicable
Additional files for all supported x64-based versions of Windows 7
File nameAmd64_02fe67ba9238f2e8509d2b5ca7505e66_31bf3856ad364e35_6.1.7601.22098_none_315b57ab809b9150.manifest
File versionNot applicable
File size733
Date (UTC)24-Aug-2012
Time (UTC)19:32
PlatformNot applicable
File nameAmd64_3c974859797a6933260217da56853525_31bf3856ad364e35_6.1.7601.22098_none_83fa268e1d6f699e.manifest
File versionNot applicable
File size726
Date (UTC)24-Aug-2012
Time (UTC)19:32
PlatformNot applicable
File nameAmd64_3ec6ef4898d2d8032b1cd58d11c7639d_31bf3856ad364e35_6.1.7601.22098_none_ab4c875ebcc12b2a.manifest
File versionNot applicable
File size726
Date (UTC)24-Aug-2012
Time (UTC)19:32
PlatformNot applicable
File nameAmd64_b5dfa89261cffc38be5a89d736904ae8_31bf3856ad364e35_6.1.7601.22098_none_9638abed2bf034fb.manifest
File versionNot applicable
File size1,094
Date (UTC)24-Aug-2012
Time (UTC)19:32
PlatformNot applicable
File nameAmd64_microsoft-windows-r..s-regkeys-component_31bf3856ad364e35_6.1.7601.22098_none_58eb1198301c8aa6.manifest
File versionNot applicable
File size3,965
Date (UTC)23-Aug-2012
Time (UTC)18:34
PlatformNot applicable
File nameAmd64_microsoft-windows-t..s-sessionenvservice_31bf3856ad364e35_6.1.7601.22098_none_3d3b576417a1a263.manifest
File versionNot applicable
File size6,606
Date (UTC)23-Aug-2012
Time (UTC)18:31
PlatformNot applicable
File nameAmd64_rdvgwddm.inf_31bf3856ad364e35_6.1.7601.22098_none_cd8cb24b8637fa46.manifest
File versionNot applicable
File size2,734
Date (UTC)23-Aug-2012
Time (UTC)18:28
PlatformNot applicable
File nameWow64_microsoft-windows-t..s-sessionenvservice_31bf3856ad364e35_6.1.7601.22098_none_479001b64c02645e.manifest
File versionNot applicable
File size4,222
Date (UTC)23-Aug-2012
Time (UTC)17:14
PlatformNot applicable

↑ Back to the top


Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseadvanced, kb

↑ Back to the top

Article Info
Article ID : 2749168
Revision : 1
Created on : 1/7/2017
Published on : 10/11/2012
Exists online : False
Views : 164