Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

"0x0000003B" Stop error when you use a Citrix XenApp application in Windows 7 or in Windows Server 2008 R2


View products that this article applies to.

Symptoms

When you use a Citrix XenApp application on a computer that is running Windows 7 or Windows Server 2008 R2, you receive a Stop error message that resembles the following:
STOP 0x0000003B (0xC0000005, Parameter2, Parameter3, Parameter4)
Notes
  • This Stop error describes a SYSTEM_SERVICE_EXCEPTION issue.
  • The parameters in this error message vary, depending on the configuration of the computer.
  • Not all "0x0000003B" Stop errors are caused by this issue.

↑ Back to the top


Cause

This issue occurs because an incorrect address pointer is sent to the Vdtw30.dll Citrix graphics driver in the Citrix XenApp application when the driver processes the DrvCopyBits function.

↑ Back to the top


Resolution

Note The hotfix of KB 2705742 is superseded by the hotfix of KB 2748302. The following section contains the hotfix information about KB 2705742. The following hotfix does not resolve all "0x0000003B" Stop errors that may occur in a Citrix XenApp environment. For more information about solution to resolve the rest of the "0x0000003B" Stop errors, go to the following Microsoft Knowledge Base article:
2748302 Stop error when you use a Citrix XenApp application in Windows 7 or in Windows Server 2008 R2


If you receive a Stop error message that resembles the following and that occurs together with the "vdtw30" stack, the issue should be resolved by KB 2748302:
STOP 0x0000003B (0x80000001, Parameter2, Parameter3,Parameter4)

Hotfix information

Prerequisites

To apply this hotfix, you must be running one of the following operating systems:
  • Windows 7
  • Windows 7 Service Pack 1 (SP1)
  • Windows Server 2008 R2
  • Windows Server 2008 R2 Service Pack 1 (SP1)
For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 and Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, milestone (RTM,SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    VersionProductMilestoneService branch
    6.1.760
    0.17xxx
    Windows 7 and Windows Server 2008 R2RTMGDR
    6.1.760
    0.21xxx
    Windows 7 and Windows Server 2008 R2RTMLDR
    6.1.760
    1.17xxx
    Windows 7 and Windows Server 2008 R2SP1GDR
    6.1.760
    1.21xxx
    Windows 7 and Windows Server 2008 R2SP1LDR
  • GDR service branches contain only those fixes that are widely released to address widespread, critical issues. LDR service branches contain hotfixes in addition to widely released fixes.
For all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
Ntkrnlpa.exe6.1.7600.170373,958,12808-Jun-201204:48Not Applicable
Ntoskrnl.exe6.1.7600.170373,902,83208-Jun-201204:48Not Applicable
Ntkrnlpa.exe6.1.7600.212293,971,44008-Jun-201206:00Not Applicable
Ntoskrnl.exe6.1.7600.212293,915,63208-Jun-201206:00Not Applicable
Ntkrnlpa.exe6.1.7601.178583,968,88008-Jun-201204:47Not Applicable
Ntoskrnl.exe6.1.7601.178583,913,07208-Jun-201204:47Not Applicable
Ntkrnlpa.exe6.1.7601.220143,972,46408-Jun-201204:28Not Applicable
Ntoskrnl.exe6.1.7601.220143,917,16808-Jun-201204:28Not Applicable
For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Ntoskrnl.exe6.1.7600.170375,505,90408-Jun-201205:30x64
Ntoskrnl.exe6.1.7600.212295,473,13608-Jun-201205:41x64
Ntoskrnl.exe6.1.7601.178585,559,66408-Jun-201205:39x64
Ntoskrnl.exe6.1.7601.220145,562,73608-Jun-201205:36x64
Ntkrnlpa.exe6.1.7600.170373,958,12808-Jun-201204:48Not Applicable
Ntoskrnl.exe6.1.7600.170373,902,83208-Jun-201204:48Not Applicable
Ntkrnlpa.exe6.1.7600.212293,971,44008-Jun-201206:00Not Applicable
Ntoskrnl.exe6.1.7600.212293,915,63208-Jun-201206:00Not Applicable
Ntkrnlpa.exe6.1.7601.178583,968,88008-Jun-201204:47Not Applicable
Ntoskrnl.exe6.1.7601.178583,913,07208-Jun-201204:47Not Applicable
Ntkrnlpa.exe6.1.7601.220143,972,46408-Jun-201204:28Not Applicable
Ntoskrnl.exe6.1.7601.220143,917,16808-Jun-201204:28Not Applicable
For all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Ntoskrnl.exe6.1.7600.1703711,177,32808-Jun-201204:18IA-64
Ntoskrnl.exe6.1.7600.2122911,141,48808-Jun-201204:15IA-64
Ntoskrnl.exe6.1.7601.1785811,120,49608-Jun-201204:16IA-64
Ntoskrnl.exe6.1.7601.2201411,129,71208-Jun-201204:24IA-64
Ntkrnlpa.exe6.1.7600.170373,958,12808-Jun-201204:48Not Applicable
Ntoskrnl.exe6.1.7600.170373,902,83208-Jun-201204:48Not Applicable
Ntkrnlpa.exe6.1.7600.212293,971,44008-Jun-201206:00Not Applicable
Ntoskrnl.exe6.1.7600.212293,915,63208-Jun-201206:00Not Applicable
Ntkrnlpa.exe6.1.7601.178583,968,88008-Jun-201204:47Not Applicable
Ntoskrnl.exe6.1.7601.178583,913,07208-Jun-201204:47Not Applicable
Ntkrnlpa.exe6.1.7601.220143,972,46408-Jun-201204:28Not Applicable
Ntoskrnl.exe6.1.7601.220143,917,16808-Jun-201204:28Not Applicable

↑ Back to the top


To resolve this issue, apply the hotfix that is described in the following Microsoft Knowledge Base article:

2748302 Stop error when you use a Citrix XenApp application in Windows 7 or in Windows Server 2008 R2

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More Information

For more information about the DrvCopyBits function, go to the following Microsoft website:For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

↑ Back to the top


Keywords: kb, kbqfe, kbhotfixserver, kbfix, kbexpertiseadvanced, kbsurveynew

↑ Back to the top

Article Info
Article ID : 2705742
Revision : 1
Created on : 1/7/2017
Published on : 12/14/2012
Exists online : False
Views : 324