Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

An error occurs when a user whose mailbox is hidden from the Exchange address list tries to open the Scheduling Assistant tab by using the light version of Outlook Web App


View products that this article applies to.

Symptoms

Consider the following scenario:
  • A mailbox user is hidden from the global address list in a Microsoft Exchange Server 2010 environment.
  • The user accesses the mailbox by using the light version of Outlook Web App.
  • The user creates an appointment or a meeting request and then clicks the Scheduling Assistant tab.
In this scenario, the user receives the following error message:
An unexpected error occurred and your request couldn’t be handled.

Request
Url: URL
User host address: Host Address
User: User
EX Address: legacyExchangeDN
SMTP Address: SMTP Address
OWA version: OWA version
Mailbox server: Mailbox server

Exception
Exception type: Microsoft.Exchange.InfoWorker.Common.Availability.MissingArgumentException
Exception message: Element Number of MailboxArray is null.

Call stack
Microsoft.Exchange.InfoWorker.Common.Availability.AvailabilityQuery.ValidateSpecificInputData()
Microsoft.Exchange.InfoWorker.Common.Availability.Query'1.ValidateInputData()
Microsoft.Exchange.InfoWorker.Common.Availability.Query'1.Execute()
Microsoft.Exchange.Clients.Owa.Core.Utilities.ExecuteAvailabilityQuery(OwaContext owaContext, AvailabilityQuery query. Boolean expectFreeBusyResults, Boolean expectMergedFreeBusyResults, AvailabilityQueryResult& result)
Microsoft.Exchange.Clients.Owa.Core.Utilities.ExecuteAvailabilityQuery(OwaContext owaContext, AvailabilityQuery query. AvailabilityQueryResult& result)
Microsoft.Exchange.Clients.Owa.Basic.CalendarItemSchedulingTab.GetFreeBusyData()
Microsoft.Exchange.Clients.Owa.Basic.CalendarItemSchedulingTab.OnLoad(EventArgs e)
System.Web.UIControl.LoadRecursive()System.Web.UIPage.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

↑ Back to the top


Cause

This issue occurs because the light version of Outlook Web App uses a Lightweight Directory Access Protocol (LDAP) query that references the showInAddressbook attribute to retrieve the user’s information from the global catalog server. However, the user does not have the showInAddressbook attribute. Therefore, a MissingArgumentException exception is thrown.


↑ Back to the top


Resolution

To resolve this issue, install the update rollup that is described in the following article in the Microsoft Knowledge Base: 
2685289 Description of Update Rollup 3 for Exchange Server 2010 Service Pack 2

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


Keywords: kbqfe, kbfix, kbsurveynew, kbexpertiseinter, kb

↑ Back to the top

Article Info
Article ID : 2705570
Revision : 1
Created on : 1/7/2017
Published on : 5/29/2012
Exists online : False
Views : 299