Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

"The file or folder does not exist" when renaming or saving to DFS share from a Windows 7 computer


View products that this article applies to.

Symptoms

When connecting from a Windows 7 computer to a DFS namespace (network file share) located on Windows Server 2008 R2, renaming or saving files located in the second subdirectory depth level (for example, z:\d1\d2) may fail with:

"The file or folder does not exist."

Also, if a file is saved to the z:\d1\d2 directory, the file will actually appear in the z:\ root directory instead.

↑ Back to the top


Cause

This problem can occur if the Windows 7 client machine connects to the DFS network file share using the \\ipaddress\SHARENAME syntax, but the client is unable to connect to the server using its name (i.e. \\servername\SHARENAME ). When a Windows 7 client connects to the \\ipaddress\SHARENAME, the server indicates that the share name is actually a DFS namespace. The client internally uses the DFS server name to track the location of the network connection, but if name resolution to the server name fails, the folder path is not tracked correctly.

↑ Back to the top


Resolution

To resolve the problem, apply the hotfix on the client computer, or follow the steps that are described in Workaround.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows 7 Service Pack 1 (SP1).

For more information about how to obtain a Windows 7 or a Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    VersionProductSR_LevelService branch
    6.1.760
    1.
    22xxx
    Windows 7 SP1LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows 7" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
Mrxsmb20.sys6.1.7601.2201396,76807-Jun-201202:22x86
For all supported x64-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
Mrxsmb20.sys6.1.7601.22013128,00007-Jun-201202:45x64

↑ Back to the top


More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows 7

Additional files for all supported x86-based versions of Windows 7
File nameUpdate.mum
File versionNot Applicable
File size2,136
Date (UTC)07-Jun-2012
Time (UTC)08:05
PlatformNot Applicable
File nameX86_1e185a624ec55ec274ac14b9cc355b04_31bf3856ad364e35_6.1.7601.22013_none_5143c74e912cd003.manifest
File versionNot Applicable
File size701
Date (UTC)07-Jun-2012
Time (UTC)08:05
PlatformNot Applicable
File nameX86_microsoft-windows-smb20-minirdr_31bf3856ad364e35_6.1.7601.22013_none_8d6ad9dc0126ab2b.manifest
File versionNot Applicable
File size4,035
Date (UTC)07-Jun-2012
Time (UTC)06:01
PlatformNot Applicable
Additional files for all supported x64-based versions of Windows 7
File nameAmd64_9e65ee6acfddfd7eb14dd4694dd6a04b_31bf3856ad364e35_6.1.7601.22013_none_0e3b97db9b019ff6.manifest
File versionNot Applicable
File size705
Date (UTC)07-Jun-2012
Time (UTC)08:05
PlatformNot Applicable
File nameAmd64_microsoft-windows-smb20-minirdr_31bf3856ad364e35_6.1.7601.22013_none_e989755fb9841c61.manifest
File versionNot Applicable
File size4,039
Date (UTC)07-Jun-2012
Time (UTC)06:56
PlatformNot Applicable
File nameUpdate.mum
File versionNot Applicable
File size2,350
Date (UTC)07-Jun-2012
Time (UTC)08:05
PlatformNot Applicable

↑ Back to the top


More Information

While the problem can be reproduced when connecting from Windows 7 to Windows Server 2008 R2, it requires a DFS namespace to be configured for SHARENAME so that the "DFS capable" bit is set on the SMB2 Tree Connect response.

After connecting to a DFS share on the server using the \\ipaddress\SHARENAME syntax, no error is displayed when name resolution to the server fails, so the file/folder access problem is not apparent.

↑ Back to the top


Workaround

To correct the problem, ensure that the Windows 7 client can connect to the server using its name, instead of its IP address. Or, reconfigure the client so that name resolution to the server name is successful. For example, make sure the client's DNS server name is correct, or add a hosts file entry to indicate the correct IP address / name mapping.

For example, from an administrative command prompt, start Notepad and open c:\windows\system32\drivers\etc\hosts , and add an entry. For example if your server name is "ServerName" and its IP address is 10.0.0.1, add:

10.0.0.1 ServerName

NOTE: The client may be able to work around the problem by always connecting to the server using the \\servername\SHARENAME syntax. This will cause the client to experience a connection error while connecting to the server if name resolution fails.

↑ Back to the top


Keywords: kb, kbqfe, kbautohotfix, kbhotfixes, kbexpertiseadvanced, kbfix

↑ Back to the top

Article Info
Article ID : 2703610
Revision : 1
Created on : 1/7/2017
Published on : 7/11/2012
Exists online : False
Views : 246