Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Incorrect delivery report when you send an email message to a recipient who has configured an external forwarding address in an Exchange Server 2010 environment


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You configure a Send connector in a Microsoft Exchange Server 2010 environment.
  • You create a mailbox in this environment.
  • You configure mail forwarding for the mailbox by using the follow configuration:
    • You set an external recipient as the forwarding address.
    • You do not select the Deliver message to both forwarding address and mailbox check box.
  • A user sends an email message to the mailbox.
  • The email message is successfully relayed to the external recipient.
In this scenario, the following tracking information is displayed in the delivery report when the user logs on to Microsoft Outlook Web App to track the email message:
Pending: Message delivery is taking longer than expected. There may be system delays. For more information contact your helpdesk.
The following tracking information is correct in this scenario:
Transferred: The message was successfully handed off to a different e-mail system. This is as far as we can track it.
Note The administrator can query the tracking information by using Exchange Control Panel or by running the search-messagetrackingreport or get-messagetrackingreport cmdlet in Exchange Management Shell.

↑ Back to the top


Cause

This issue occurs because a function in a message tracking component tries to obtain the information for the recipient instead of the external recipient to which the email message is forwarded.

↑ Back to the top


Resolution

To resolve this issue, install the following update rollup:
2661854 Description of Update Rollup 2 for Exchange Server 2010 Service Pack 2

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More Information

For more information about how to configure mail forwarding for a mailbox, visit the following Microsoft website:For more information about Send connectors, visit the following Microsoft website:For more information about the Exchange 2010 Delivery Reports feature, visit the following Microsoft website:For more information about the Search-MessageTrackingReport cmdlet, visit the following Microsoft website:For more information about the Get-MessageTrackingReport cmdlet, visit the following Microsoft website:

↑ Back to the top


Keywords: kbqfe, kbfix, kbsurveynew, kbexpertiseinter, kb

↑ Back to the top

Article Info
Article ID : 2694474
Revision : 1
Created on : 1/7/2017
Published on : 4/16/2012
Exists online : False
Views : 221