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You cannot access a mailbox for several hours after you disconnect and then reconnect the mailbox in an Exchange Server 2010 SP2 environment


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You disable a mailbox in a Microsoft Exchange Server 2010 Service Pack 2 (SP2) environment.
  • You reconnect the mailbox.

    Note To reconnect the mailbox, start the Exchange Management Console (EMC) in the Disconnected Mailbox node. To complete the operation, click the Finish button when you receive the following warning message: 
    The operation completed successfully but the change will not become effective until Active Directory replication occurs.
  • You try to access the mailbox by using Microsoft Outlook or Outlook Web App.
In this scenario, you must wait several hours before you can access the mailbox.
If you update the Disconnected Mailbox result pane during this time, the mailbox appears in the result pane.
Additionally, if you run the test-mapiconnectivity cmdlet, the cmdlet fails and you receive the following error message:
Server : Server 
Database : Database
Mailbox : Mailbox 
Result : *FAILURE* 
Latency : Latency 
Error : [Microsoft.Exchange.Data.Storage.AccountDisabledException]: Cannot open mailbox LegacyDN. Inner error [Microsoft.Mapi.MapiExceptionMailboxDisabled]: MapiExceptionMailboxDisabled: Unable to open message store. (hr=0x80004005, ec=2412)

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Cause

This issue occurs because Directory Service Access (DSAccess) caches a query for the disconnected mailbox when the mailbox is not found in Active Directory. More specifically, DSAccess caches a query that cannot find the disconnected mailbox.

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Resolution

To resolve this issue, install the following update rollup:
2685289 Description of Update Rollup 3 for Exchange Server 2010 Service Pack 2

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Workaround

To work around this issue, run the Clean-MailboxDatabase cmdlet to scan Active Directory for disconnected mailboxes and to update the status of the mailboxes in the Exchange store.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about the Clean-MailboxDatabase cmdlet, go to the following Microsoft website:For more information about DSAccess, go to the following Microsoft website:

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Keywords: kbqfe, kbfix, kbsurveynew, kbexpertiseinter, kb

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Article Info
Article ID : 2682047
Revision : 1
Created on : 1/7/2017
Published on : 5/29/2012
Exists online : False
Views : 373