Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

The user-agent information about an Exchange ActiveSync device is not updated in an Exchange Server 2010 environment


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You access a mailbox in an Exchange Server 2010 environment by using an Exchange ActiveSync device to connect to a Microsoft Exchange Server 2010 Client Access server.
  • You make some changes that change the user-agent information about the device. For example, you update the operating system version on the device. 
  • The administrator runs the Get-ActiveSyncDeviceStatistics cmdlet to retrieve the device statistics.
In this scenario, the cmdlet returns an out of date version of the user-agent information instead of the latest user-agent information.

↑ Back to the top


Cause

This issue occurs because Exchange ActiveSync does not recognize the changes of the user-agent string. Therefore, Active Directory Domain Services (AD DS) is not updated with the latest user-agent information.

↑ Back to the top


Resolution

To resolve this issue, install the following cumulative update:
2661854 Description of Update Rollup 2 for Exchange Server 2010 Service Pack 2

↑ Back to the top


More Information

For more information about the Get-ActiveSyncDeviceStatistics cmdlet, visit the following Microsoft website:For more information about user-agent strings, visit the following Microsoft website:For more information about Exchange ActiveSync, visit the following Microsoft website:
The Troubleshoot ActiveSync with Exchange Server guided walkthrough helps troubleshoot the following issues:

  • Unable to create a profile on the device
  • Unable to connect to the server
  • Mail issues
  • Calendaring issues
  • Delays on device/CAS performance

↑ Back to the top


Keywords: kbqfe, kbfix, kbsurveynew, kbexpertiseinter, kbgwt, kb

↑ Back to the top

Article Info
Article ID : 2678361
Revision : 1
Created on : 1/7/2017
Published on : 2/18/2014
Exists online : False
Views : 234