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IP packets are not routed through a Windows Server 2008 R2–based LAN router in a VLAN environment


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You install the Routing and Remote Access role service on a multi-homed computer that is running Windows Server 2008 R2.
  • You configure the computer as a Local Area Network (LAN) router between two network segments.
  • The Virtual LAN (VLAN) option is enabled in only one network segment.
  • An un-tagged side of the two VLAN network segments consists of a pure LAN connection or an IPsec site-to-site tunnel.
  • You send IP packets from the tagged VLAN network segment to the un-tagged VLAN network segment through the LAN router.
In this scenario, the IP packets are not routed to their destination hosts in the un-tagged network segment.

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Cause

This issue occurs because the VLAN tag is not removed from the IP packets that are forwarded from the tagged VLAN network segment to an un-tagged side or an IPsec site-to-site tunnel.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 R2 Service Pack 1 (SP1).

For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To apply the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    VersionProductSR_LevelService branch
    6.1.760
    1.
    17xxx
    Windows Server 2008 R2SP1GDR
    6.1.760
    1.
    21xxx
    Windows Server 2008 R2SP1LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTime
Fwpkclnt.sys6.1.7601.17514288,64020-Nov-201013:33
Tcpip.sys6.1.7601.177541,923,44003-Jan-201206:42
Fwpkclnt.sys6.1.7601.21889288,62403-Jan-201206:35
Tcpip.sys6.1.7601.218891,901,42403-Jan-201206:35
For all supported IA-64–based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTime
Fwpkclnt.sys6.1.7601.17514483,20020-Nov-201010:33
Tcpip.sys6.1.7601.177543,789,16803-Jan-201205:08
Fwpkclnt.sys6.1.7601.21889483,18403-Jan-201205:23
Tcpip.sys6.1.7601.218893,807,08803-Jan-201205:24

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2
File nameAmd64_c126dc2c15d35dff969569851031380d_31bf3856ad364e35_6.1.7601.21889_none_7ab903fcac123fab.manifest
File versionNot applicable
File size706
Date (UTC)04-Jan-2012
Time (UTC)01:57
File nameAmd64_f056c50eafd84e153ae708d56fddaf45_31bf3856ad364e35_6.1.7601.17754_none_0647f8490e4d4e2d.manifest
File versionNot applicable
File size706
Date (UTC)04-Jan-2012
Time (UTC)01:57
File nameAmd64_microsoft-windows-tcpip-binaries_31bf3856ad364e35_6.1.7601.17754_none_1118dbdd7d263549.manifest
File versionNot applicable
File size3,784
Date (UTC)04-Jan-2012
Time (UTC)02:08
File nameAmd64_microsoft-windows-tcpip-binaries_31bf3856ad364e35_6.1.7601.21889_none_11870a569657a799.manifest
File versionNot applicable
File size3,838
Date (UTC)03-Jan-2012
Time (UTC)07:02
Additional files for all supported IA-64–based versions of Windows Server 2008 R2
File nameIa64_09578244f9fff7c926112b2b7946a9ad_31bf3856ad364e35_6.1.7601.17754_none_cf530ff439888a7a.manifest
File versionNot applicable
File size704
Date (UTC)04-Jan-2012
Time (UTC)01:57
File nameIa64_ad158e166ba07840e20d1bfeb1b236ff_31bf3856ad364e35_6.1.7601.21889_none_f30ef4f6ef031684.manifest
File versionNot applicable
File size704
Date (UTC)04-Jan-2012
Time (UTC)01:57
File nameIa64_microsoft-windows-tcpip-binaries_31bf3856ad364e35_6.1.7601.17754_none_b4fbe44fc4c6cd0f.manifest
File versionNot applicable
File size3,782
Date (UTC)04-Jan-2012
Time (UTC)01:57
File nameIa64_microsoft-windows-tcpip-binaries_31bf3856ad364e35_6.1.7601.21889_none_b56a12c8ddf83f5f.manifest
File versionNot applicable
File size3,836
Date (UTC)03-Jan-2012
Time (UTC)06:47

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Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseinter

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Article Info
Article ID : 2661010
Revision : 1
Created on : 1/7/2017
Published on : 1/4/2013
Exists online : False
Views : 199