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FIX: Japanese characters in the subject line of an Alert email message are not readable in the Japanese version of Forefront Threat Management Gateway 2010


View products that this article applies to.

Symptoms

In the Japanese version of Microsoft Forefront Threat Management Gateway (TMG) 2010, when you use the Alert mail function to send an email message to the administrator, you may receive an Alert email message in which the Japanese characters in the subject line are not readable.

For example, you may receive an Alert email message from Forefront Threat Management Gateway to the Simple Mail Transfer Protocol (SMTP) server whose subject line resembles one of the following:
Subject: Microsoft Forefront TMG - è¦å‘Šãƒ†ã‚¹ãƒˆ メール

Subject: Microsoft Forefront TMG - ??????????????? ????????

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Cause

This problem occurs because the encoding format for specifying the character set is not included in the subject header of the Forefront TMG Alert email message.

The raw Japanese characters are written in the "Subject:" header. An affected email client cannot detect the correct character set when the client displays the subject line. This results in unreadable, non-Japanese characters.

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Resolution

To resolve this issue, follow these steps:

  1. Install the hotfix package that is described in the following article in the Microsoft Knowledge Base. (Or, install a more recent service pack if one is available.)  
    2649961 Rollup 1 for Forefront Threat Management Gateway (TMG) 2010 Service Pack 2
  2. Copy the following text into a file that is named Enable265591.vbs: 

    Set objCurrentArray = CreateObject("FPC.Root").GetContainingArray


    objCurrentArray.MailCodePage = 130537


    objCurrentArray.Save
  3. Run the Enable265591.vbs script in an elevated command prompt on any TMG stand-alone or array member. You have to run the script one time for each array.
You do not have to restart the computer. The setting becomes effective shortly after you run the script, as with any other array configuration change.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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References

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbnotautohotfix, kbexpertiseinter, kbbug, kbsurveynew, kbqfe, kbfix, kb

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Article Info
Article ID : 2655951
Revision : 1
Created on : 1/7/2017
Published on : 10/10/2012
Exists online : False
Views : 339