Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Data corruption when one user on a computer that is running Windows 7 or Windows Server 2008 R2 updates a shared file that is open on multiple computers by using SMB Version 2


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You share a file on a computer that is running Windows 7 or Windows Server 2008 R2.
  • Multiple users open the file by using the Server Message Block (SMB) Version 2 protocol from multiple remote computers.
  • One of the users updates the file.
In this scenario, data corruption may occur.

Note By default, the SMB Version 2 protocol is enabled in the following operating systems:
  • Windows 7
  • Windows Server 2008 R2
  • Windows Vista
  • Windows Server 2008

↑ Back to the top


Cause

This issue occurs because the SMB redirector (Mrxsmb20.sys) incorrectly reports the position of the end of the file. Therefore, an application may unknowingly request to write to an incorrect location and cause the file to be corrupted.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running one of the following operating systems:
  • Windows 7
  • Windows 7 Service Pack 1 (SP1)
  • Windows Server 2008 R2
  • Windows Server 2008 R2 Service Pack 1 (SP1)
For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 and Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    VersionProductSR_LevelService branch
    6.1.760
    0.
    21xxx
    Windows 7 and Windows Server 2008 R2RTMLDR
    6.1.760
    1.
    21xxx
    Windows 7 and Windows Server 2008 R2SP1LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2 and for Windows 7" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
Mrxsmb20.sys6.1.7600.2105797,28017-Sep-201122:39x86
Mrxsmb20.sys6.1.7601.2182296,76817-Sep-201123:50x86
For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Mrxsmb20.sys6.1.7600.21057128,51217-Sep-201122:58x64
Mrxsmb20.sys6.1.7601.21822128,00017-Sep-201123:49x64
For all supported IA-64–based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Mrxsmb20.sys6.1.7600.21057313,34417-Sep-201122:20IA-64
Mrxsmb20.sys6.1.7601.21822310,78417-Sep-201122:18IA-64

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

For more information about a similar issue, click the following article number to view the article in the Microsoft Knowledge Base:
2028965 Data corruption when multiple users perform read and write operations to a shared file in the SMB2 environment

Additional file information

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7
File nameUpdate.mum
File versionNot applicable
File size2,773
Date (UTC)18-Sep-2011
Time (UTC)07:45
PlatformNot applicable
File nameX86_5580f8cdd662ece1f532e40f7b175465_31bf3856ad364e35_6.1.7601.21822_none_4b2d9c6fe908c864.manifest
File versionNot applicable
File size701
Date (UTC)18-Sep-2011
Time (UTC)07:45
PlatformNot applicable
File nameX86_5ab6c295a7a9824b9fdfa31b040e15cb_31bf3856ad364e35_6.1.7600.21057_none_50c708effdb04d19.manifest
File versionNot applicable
File size701
Date (UTC)18-Sep-2011
Time (UTC)07:45
PlatformNot applicable
File nameX86_microsoft-windows-smb20-minirdr_31bf3856ad364e35_6.1.7600.21057_none_8b5d3a82041d1a11.manifest
File versionNot applicable
File size4,035
Date (UTC)18-Sep-2011
Time (UTC)01:36
PlatformNot applicable
File nameX86_microsoft-windows-smb20-minirdr_31bf3856ad364e35_6.1.7601.21822_none_8d5f2f9e012f7d5c.manifest
File versionNot applicable
File size4,035
Date (UTC)18-Sep-2011
Time (UTC)03:15
PlatformNot applicable
Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameAmd64_5f3240e27a970e5e8fb97cbfd1bf0419_31bf3856ad364e35_6.1.7600.21057_none_e95b60bbea8b7db8.manifest
File versionNot applicable
File size705
Date (UTC)18-Sep-2011
Time (UTC)07:45
PlatformNot applicable
File nameAmd64_eea11ce079e9dda4bc2adaff089dbe57_31bf3856ad364e35_6.1.7601.21822_none_5cfb22d6211ab548.manifest
File versionNot applicable
File size705
Date (UTC)18-Sep-2011
Time (UTC)07:45
PlatformNot applicable
File nameAmd64_microsoft-windows-smb20-minirdr_31bf3856ad364e35_6.1.7600.21057_none_e77bd605bc7a8b47.manifest
File versionNot applicable
File size4,039
Date (UTC)18-Sep-2011
Time (UTC)02:18
PlatformNot applicable
File nameAmd64_microsoft-windows-smb20-minirdr_31bf3856ad364e35_6.1.7601.21822_none_e97dcb21b98cee92.manifest
File versionNot applicable
File size4,039
Date (UTC)18-Sep-2011
Time (UTC)04:27
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size3,215
Date (UTC)18-Sep-2011
Time (UTC)07:45
PlatformNot applicable
Additional files for all supported IA-64–based versions of Windows Server 2008 R2
File nameIa64_0c1639807add3edf1563af25e3f262d8_31bf3856ad364e35_6.1.7601.21822_none_8bc599fc49590fa2.manifest
File versionNot applicable
File size703
Date (UTC)18-Sep-2011
Time (UTC)07:45
PlatformNot applicable
File nameIa64_25d2bac3af5b2a31f1b4a542796d7f5a_31bf3856ad364e35_6.1.7600.21057_none_9044fcafeb13bf3b.manifest
File versionNot applicable
File size703
Date (UTC)18-Sep-2011
Time (UTC)07:45
PlatformNot applicable
File nameIa64_microsoft-windows-smb20-minirdr_31bf3856ad364e35_6.1.7600.21057_none_8b5ede78041b230d.manifest
File versionNot applicable
File size4,037
Date (UTC)18-Sep-2011
Time (UTC)02:24
PlatformNot applicable
File nameIa64_microsoft-windows-smb20-minirdr_31bf3856ad364e35_6.1.7601.21822_none_8d60d394012d8658.manifest
File versionNot applicable
File size4,037
Date (UTC)18-Sep-2011
Time (UTC)04:04
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size2,168
Date (UTC)18-Sep-2011
Time (UTC)07:45
PlatformNot applicable

↑ Back to the top


Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsmb, kbsurveynew, kbexpertiseadvanced

↑ Back to the top

Article Info
Article ID : 2618096
Revision : 1
Created on : 1/7/2017
Published on : 12/28/2012
Exists online : False
Views : 293