Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

FIX: "0x80070002" error in Forefront Threat Management Gateway 2010 when an array join operation fails


View products that this article applies to.

Symptoms

You try to join a Microsoft Forefront Threat Management Gateway (TMG) 2010 server to an array. However, the array join operation fails, and you receive the following error message:
The Operation Failed. Error code - 0x80070002 - the system cannot find the file specified

↑ Back to the top


Cause

This problem occurs if the BUILT IN\Administrators group is removed from the TMG Enterprise Administrators role. When this group is removed, the permissions that are needed for a server to join an array are also removed.

↑ Back to the top


Resolution

TMG 2010 does not support removing the BUILT IN\Administrators group from the TMG Enterprise Administrators group. To resolve this problem, add the BUILT IN\Administrators group back to the TMG Enterprise Administrators role.

To block removal of the BUILT IN\Administrators group, install Microsoft Forefront Threat Management Gateway 2010 Service Pack 2. This service pack blocks removal of the BUILT IN\Administrators group from the TMG Enterprise Administrators role:
2555840 Description of Service Pack 2 for Microsoft Forefront Threat Management Gateway 2010
Note The Forefront TMG limitation that is described in this article was addressed in Rollup 2 for Forefront TMG Service Pack 2 (KB 2689195). Rollup 2 provides support for the removal of the BUILT IN\Administrators group from the TMG Enterprise Administrators role. For more information about Rollup 2, click the following article number to view the article in the Microsoft Knowledge Base:  
2689195 Rollup 2 for Forefront Threat Management Gateway (TMG) 2010 Service Pack 2

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More Information

You may also receive the error message that is mentioned in the "Symptoms" section if a firewall is configured between the array member and the Enterprise Management Server (EMS). This configuration can interfere with remote procedure call (RPC) communications between an array member and the EMS server.

↑ Back to the top


References

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: kbfix, kbbug, kbexpertiseinter, kbsurveynew, kb

↑ Back to the top

Article Info
Article ID : 2595999
Revision : 1
Created on : 1/7/2017
Published on : 5/22/2013
Exists online : False
Views : 323