Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Retention policies are applied to Contact items unexpectedly in an Exchange Server 2010 environment


View products that this article applies to.

Symptoms

Consider the following scenario:


  • You have a Microsoft Exchange Server 2010 server that has the Mailbox role installed.
  • You configure the regional language settings of Exchange server to a language other than English.
  • Certain characters in the language have different uppercase and lowercase versions. For example, the lowercase character of "I" in Turkish is not "i", but a dot-less "ı".
  • You apply retention policies to mailboxes.

In this scenario, the retention policies are also applied to Contact items of the mailboxes unexpectedly.

↑ Back to the top


Cause

This issue occurs because the Microsoft Exchange Mailbox Assistants service uses an incorrect method for item class comparison when retention policies are executed. The case-insensitive comparison fails after an uppercase to lowercase conversion. Therefore, Contact items are included in retention policies.

↑ Back to the top


Resolution

To resolve this issue, install the following update rollup:
2608646 Description of Update Rollup 6 for Exchange Server 2010 Service Pack 1

↑ Back to the top


Workaround

To work around this issue, change the locale to English (United States). To do this, follow these steps:
  1. Click Start, and then click Run.
  2. Type intl.cpl in the Open box, and then click OK to start Region and Language.
  3. On the Formats tab, select English (United States) in the Format list.
  4. On the Administrative tab, click Change system locale.
  5. Click English (United States) in the Current system locale list, and then click OK.
  6. Click OK in the Region and Language dialog box.
  7. Restart the server.


↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More Information

For more information about retention tags and retention policies, visit the following Microsoft website:
For more information about how to create a retention policy, visit the following Microsoft website:
For more information about how to apply a retention policy to mailboxes, visit the following Microsoft website:

↑ Back to the top


Keywords: kbqfe, kbfix, kbsurveynew, kbexpertiseinter, kb

↑ Back to the top

Article Info
Article ID : 2571791
Revision : 1
Created on : 1/7/2017
Published on : 10/28/2011
Exists online : False
Views : 292