Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Records are not always written to the Workflowlogbase table for single-step workflows after Update Rollup 1 for Microsoft Dynamics CRM 2011 is installed


View products that this article applies to.

Symptoms

When you have a single-step workflow that does not include Wait, Condition, or Stage steps and the Automatically delete completed workflow jobs (to save disk space) option is selected, records will not be written to the Workflowlogbase table.

↑ Back to the top


Cause

An optimization change was made in Update Rollup 1 to reduce database round trips and to save disk space. This optimization only applies to workflows that are created in the web application.

↑ Back to the top


More Information

After Update Rollup 1 for Microsoft Dynamics CRM 2011 is installed, any workflows that are triggered and that get evaluated as a single-step workflow that does not include Wait, Condition, or Stage steps will not log any information to the Workflowlogbase table. If you have existing single-step workflows that are currently in a Wait state when Update Rollup 1 is installed, those workflows will still write to the Workflowlogbase table.  

Because of this change, a red "X" will no longer appear next to a step that failed in your single-step workflows.

↑ Back to the top


Keywords: kbmbspartner, kbmbsmigrate, kbsurveynew, kb

↑ Back to the top

Article Info
Article ID : 2526154
Revision : 1
Created on : 1/7/2017
Published on : 4/7/2011
Exists online : False
Views : 300