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You cannot send an email message to a mailbox for a brief period when you move the mailbox by using online move in an Exchange Server 2010 environment


Symptoms

Consider the following scenario:
  • You move a large mailbox by using online mailbox move in a Microsoft Exchange Server 2010 environment.
  • You send an email message to the mailbox at the end of the move process. For example, when the move process is around 95%.
In this scenario, you may receive the following non-delivery report (NDR) message:
"STOREDRV.Deliver.Exception:StoragePermanentException.MapiExceptionMailboxSoftDeleted".
Below is a sample of a NDR message when this issue occurs:
From: Microsoft Outlook
Sent: <date & time>
To: <email address>
Subject: Undeliverable: <subject name>
Delivery has failed to these recipients or groups:
<email address>
There's a problem with the recipient's mailbox. Please try resending the message. If the problem continues, please contact your helpdesk.
Diagnostic information for administrators:
Generating server: <server name>
<address name>
#554 5.2.0 STOREDRV.Deliver.Exception:StoragePermanentException.MapiExceptionMailboxSoftDeleted; Failed to process message due to a permanent exception with message Cannot open mailbox <address of the mailbox>
Note: You may also experience other mailbox access issue after a mailbox move when Active Directory is pointing to a soft deleted mailbox instead of the active mailbox.

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Cause

This issue occurs because the source mailbox is soft deleted at the end of the move operation. However, Active Directory could still point to the soft deleted mailbox instead of the active mailbox due to AD replication latency. If an email message is sent to the mailbox during this time, and the transport service is using lagged AD mailbox information, the exception causes the NDR message that is mentioned in the “Symptom” section.

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Resolution

To resolve this issue, install the following update rollup:
2579150 Description of Update Rollup 4 for Exchange Server 2010 Service Pack 1

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Workaround

To work around this issue, move the mailbox by using the Offline move mailbox feature.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about move requests, visit the following Microsoft website:

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Keywords: kbqfe, kbfix, kbsurveynew, kbexpertiseinter, kbhotfixrollup, kb

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Article Info
Article ID : 2511897
Revision : 2
Created on : 9/20/2018
Published on : 9/20/2018
Exists online : False
Views : 273