Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

"The item cannot be saved to this folder." error message when try to post an item to a mail-disabled public folder in an Exchange Server 2010 SP1 environment


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You configure the Maximum receive size (KB) transport setting and the Maximum send size (KB) transport setting on a Microsoft Exchange Server 2010 Service Pack 1 (SP1) server.
  • You configure the maximum size for posted items on a mail-disabled public folder.
  • The maximum size for posted items on the mail-disabled public folder is larger than the value of the Maximum receive size (KB) and the Maximum send size (KB) transport setting.
  • You try to post an item to the public folder. The item is larger than the value of the Maximum receive size (KB) transport setting and the Maximum send size (KB) transport setting. However, it is smaller than the maximum size for posted items on the mail-disabled public folder.
In this scenario, you cannot post the item. Additionally, you receive the following error message:

The item cannot be saved to this folder. The folder was deleted or moved, or you do not have permission. Do you want to save a copy of it in the default folder for the item?

↑ Back to the top


Cause

This issue occurs because Exchange Server 2010 SP1 incorrectly applies the limit of the Maximum receive size (KB) transport setting and the limit of the Maximum send size (KB) transport setting on mail-disabled public folders.

↑ Back to the top


Resolution

To resolve this issue, install the following update rollup:
2579150 Description of Update Rollup 4 for Exchange Server 2010 Service Pack 1
After you apply this update, create the following registry subkey on the server:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersPublicName: Enforce Transport Size Limits For Non-Mail-Enabled PFs
Type: DWORD
Value: 0

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More Information

You can run the Set-PublicFolder cmdlet together with the MaxItemSize parameter in the Exchange Management Shell to configure the maximum size for posted items on a public folder. For more information about the Set-PublicFolder cmdlet, visit the following Microsoft website:For more information about how to configure transport settings, visit the following Microsoft website:For more information about how to mail-disable a public folder, visit the following Microsoft website:For more information about message size limits, visit the following Microsoft website:

↑ Back to the top


Keywords: kbqfe, kbfix, kbsurveynew, kbexpertiseinter, kbhotfixrollup, kb

↑ Back to the top

Article Info
Article ID : 2492068
Revision : 1
Created on : 1/7/2017
Published on : 10/19/2011
Exists online : False
Views : 354