Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

A content search fails in an IMAP client application that connects to an Exchange Server 2010 mailbox


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You use an Internet Message Access Protocol version 4 (IMAP4) client application to connect to a Microsoft Exchange Server 2010 mailbox.
  • You perform a content search on the mailbox. This causes the client application to call the UID SEARCH TEXT {n} IMAP command to the Exchange Server 2010 server.
In this scenario, the IMAP4 service on the Exchange Server 2010 server does not send a response. Therefore, the IMAP client application is not responding and the content search fails.

↑ Back to the top


Cause

This issue occurs because Exchange Server 2010 can only respond to the SEARCH TEXT {n} IMAP command. However, Exchange Server 2010 does not respond to the SEARCH TEXT {n} command if UID is included.

↑ Back to the top


Resolution

To resolve this issue, install the following update rollup:
2529939 Description of Update Rollup 3 for Exchange Server 2010 Service Pack 1

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


Keywords: kbqfe, kbfix, kbsurveynew, kbexpertiseinter, kbhotfixrollup, kb

↑ Back to the top

Article Info
Article ID : 2482471
Revision : 1
Created on : 1/7/2017
Published on : 4/7/2011
Exists online : False
Views : 286