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The print job fails when you try to print to a non-Windows-based IPP server on a client computer that is running Windows 7 or Windows Server 2008 R2


View products that this article applies to.

Symptoms

You have a client computer that is running Windows 7 or Windows Server 2008 R2. When you try to print to a non-Windows-based Internet Printing Protocol (IPP) server, the print job fails.

This issue occurs if the following conditions are true:
  • The IPP server requires Basic authentication.
  • The print job is large.

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Cause

This issue occurs because Windows does not correctly listen for replies from the IPP server when a print job is spanned over multiple TCP packets. Some IPP implementations reply to IPP job requests after they receive the first packet. However, Windows listens for the job status message only after it sends all the packets in the print job. Therefore, if the print job is large, the operating system does not receive Access Denied responsesin a timely manner and resends the print job with authentication.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows 7 or Windows Server 2008 R2.

Registry information

To use this hotfix, you do not have to make any changes to the registry.

Restart requirement

You may have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 and Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2 and for Windows 7" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are very important for maintaining the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
Inetpp.dll6.1.7600.20757125,44017-Jul-201007:24x86
Inetppui.dll6.1.7600.1638518,94414-Jul-200901:15x86
Wpnpinst.exe6.1.7600.1638539,42414-Jul-200901:14x86
For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Inetpp.dll6.1.7600.20757165,37617-Jul-201008:05x64
Inetppui.dll6.1.7600.1638522,52814-Jul-200901:41x64
Wpnpinst.exe6.1.7600.1638548,64014-Jul-200901:39x64
For all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Inetpp.dll6.1.7600.20757396,28817-Jul-201006:42IA-64
Inetppui.dll6.1.7600.1638551,71214-Jul-200901:46IA-64
Wpnpinst.exe6.1.7600.16385127,48814-Jul-200901:45IA-64

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Workaround

To work around this issue, disable Basic authentication on the IPP server.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about IPP, visit the following Microsoft website:For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7
File nameX86_60b5b9e4fedcedb55cf70b52ffbe7089_31bf3856ad364e35_6.1.7600.20757_none_b0f4331760e5ee92.manifest
File versionNot applicable
File size720
Date (UTC)19-Jul-2010
Time (UTC)13:13
PlatformNot applicable
File nameX86_microsoft-windows-p..rnetprinting-client_31bf3856ad364e35_6.1.7600.20757_none_8b54cea642ba45cd.manifest
File versionNot applicable
File size5,259
Date (UTC)19-Jul-2010
Time (UTC)13:17
PlatformNot applicable
Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameAmd64_791ba12cb5d4c75efb2dbfdabbc769dd_31bf3856ad364e35_6.1.7600.20757_none_d0ab81e39833c3ed.manifest
File versionNot applicable
File size724
Date (UTC)19-Jul-2010
Time (UTC)13:13
PlatformNot applicable
File nameAmd64_microsoft-windows-p..rnetprinting-client_31bf3856ad364e35_6.1.7600.20757_none_e7736a29fb17b703.manifest
File versionNot applicable
File size5,263
Date (UTC)19-Jul-2010
Time (UTC)13:20
PlatformNot applicable
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
File nameIa64_be1ce4f00e932b133309f5253148c503_31bf3856ad364e35_6.1.7600.20757_none_2dcd5bf5c91e5e6d.manifest
File versionNot applicable
File size722
Date (UTC)19-Jul-2010
Time (UTC)13:13
PlatformNot applicable
File nameIa64_microsoft-windows-p..rnetprinting-client_31bf3856ad364e35_6.1.7600.20757_none_8b56729c42b84ec9.manifest
File versionNot applicable
File size5,261
Date (UTC)19-Jul-2010
Time (UTC)13:13
PlatformNot applicable

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Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseinter

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Article Info
Article ID : 2280758
Revision : 2
Created on : 9/18/2018
Published on : 9/18/2018
Exists online : False
Views : 192