Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

"Could not load type 'System.Security.Authentication.ExtendedProtection.ExtendedProtectionPolicy'" exception error after you install update 982167 or update 982168


View products that this article applies to.

Symptoms

After you install update 982167 or update 982168, you may receive an exception error message that resembles the following when you run Windows Communication Foundation-based applications:

Could not load type 'System.Security.Authentication.ExtendedProtection.ExtendedProtectionPolicy

↑ Back to the top


Cause

Update 982167 and update 982168 update the .NET Framework 2.0 feature layer in the .NET Framework 3.5 SP1 to introduce the new type 'System.Security.Authentication.ExtendedProtection.ExtendedProtectionPolicy'. This new type is used by the corresponding new feature in Windows Communication Foundation.

The error occurs because the underlying .NET Framework 2.0 SP2 Network Client Library feature layer is not updated when the Windows Communication Foundation feature layer is updated to use the new type. The underlying .NET Framework 2.0 SP2 Network Client Library feature layer does not support this new type, and so this error is thrown.






This scenario may occur for several reasons, including certain installation failure issues that are related to dual branch servicing. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
960043 Dual Branch Servicing for the .NET Framework 2.0 Service Pack 2, the .NET Framework 3.0 Service Pack 2, and the .NET Framework 3.5 Service Pack 1

↑ Back to the top


Workaround

To work around this problem, follow these steps:
  1. Install hotfix 975954. To download the MSI updates, visit the following MSDN webpage:
  2. Run a repair of the product. We can repair the product for you automatically or you may repair the product yourself.

    Fix it for me

    To run a repair of the product automatically, click the Fix this problemlink. Then click
    Run in the File Downloaddialog box, and follow the steps in this wizard.

    NoteThis wizard is temporarily in English only. However, the automatic fix also works for other language versions of Windows.


    NoteIf you are not on the computer that has the problem, you can save the automatic fix to a flash drive or a CD so that you can run it on the computer that has the problem.


    Let me fix it myself

    To repair the product yourself, type the following command from an elevated command prompt:
    msiexec /f {C09FB3CD-3D0C-3F2D-899A-6A1D67F2073F}

    This causes all features in the .NET Framework 2.0 SP2 product to reevaluate its installation state.
    This resolves the issue and allows for update 982167 or 982168 to apply their respective payloads.
Note If steps 1 and 2 do not work, try uninstalling the update that you installed before you experienced the error, and then reinstall the update.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More Information

For more information about how to run a command with elevated privileges, visit the following Microsoft webpage: For more information about the command-line switches that are supported by Windows Installer, visit the following MSDN webpage: For more information about Windows Installer, visit the following MSDN webpage:

↑ Back to the top


Keywords: kb, kbbug, kbexpertiseinter, kbinfo, kblangall, kbmustloc, kbsecreview, kbsecurity, kbsurveynew, kbfablepc, kbmsifixme, kbfixme

↑ Back to the top

Article Info
Article ID : 2262911
Revision : 1
Created on : 1/7/2017
Published on : 9/11/2013
Exists online : False
Views : 484