Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

You receive "Can't update. Database or object is read-only" error message when you import or export files in Access 2000


Moderate: Requires basic macro, coding, and interoperability skills.

This article applies to a Microsoft Access database (.mdb) and to a Microsoft Access project (.adp).

↑ Back to the top


Symptoms

After you install the latest service pack for Microsoft Jet 4.0, when you import text files or try to export an Access object to text format, you may receive the following error message:
Can't update. Database or object is read-only.
When importing, this is followed by:
An error occurred trying to import file
filename. The file was not imported.

↑ Back to the top


Cause

The file that you are importing or that you are trying to export does not have a recognized file name extension.

↑ Back to the top


Resolution

Rename the file name extension so that it matches one of extensions listed in the "More Information" section later in this article.


-or-

Modify the following registry key to include the extension of the file that you are importing.

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows
HKEY_LOCAL_MACHINE\Software\Microsoft\Jet\4.0\Engines\Text\DisabledExtensions
For additional information about setting this registry key see the More Information section of the following article, click the article number below to view the article in the Microsoft Knowledge Base:
239471 Jet 4.0 Text IISAM Allows Users to Append Lines to System Files

↑ Back to the top


More Information

For security reasons, the latest service pack for Jet (by default) allows only text files with the following extensions to be imported:
  • txt
  • csv
  • tab
  • asc
  • htm
  • html
If you try to import a text file or to export an Access object to text format with any other extension, you receive the error message that is mentioned in the "Symptoms" section.

Steps to Reproduce the Behavior

  1. Install Microsoft Jet 4.0 Service Pack 3. For additional information about installing this service pack, click the following article number to view the article in the Microsoft Knowledge Base:
    239114 How to obtain the latest service pack for the Microsoft Jet 4.0 Database Engine

  2. Click Start, point to Programs, point to Accessories, and then click Notepad.
  3. Type the following text:

    1,John,Doe
    2,John,Smith
    3,John,Jones
  4. Save the file as C:\Test.dat, and then close it.
  5. Start Microsoft Access 2000.
  6. Create a new database.
  7. On the File menu, point to Get External Data, and then click Import.
  8. In the Files of type list, click
    Text Files (*.txt;*.csv;*.tab;*.asc).
  9. In the File name box, type
    C:\Test.dat, and then press ENTER.
  10. Click Finish. Note that you receive the following error message:
    Can't update. Database or object is read-only.

↑ Back to the top


Keywords: kbsweptsoltax, kbexport, kbimport, kbsweptjet4sp, kberrmsg, kbprb, kb, kbarchive

↑ Back to the top

Article Info
Article ID : 245407
Revision : 3
Created on : 4/17/2018
Published on : 4/18/2018
Exists online : False
Views : 288